aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Mini
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 07:54:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 07:54:56 +0000
commit9001c210aaa647cf28d398634273edcf4f61b57b (patch)
tree22692aa5a47dc5a9cbfedebfb426313bf2251d89 /textproc/p5-XML-Mini
parentdc1b803ac4ade2954c423afcab2fad21c76809a7 (diff)
downloadports-9001c210aaa647cf28d398634273edcf4f61b57b.tar.gz
ports-9001c210aaa647cf28d398634273edcf4f61b57b.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Mini')
-rw-r--r--textproc/p5-XML-Mini/Makefile28
-rw-r--r--textproc/p5-XML-Mini/distinfo3
-rw-r--r--textproc/p5-XML-Mini/pkg-descr6
-rw-r--r--textproc/p5-XML-Mini/pkg-plist16
4 files changed, 53 insertions, 0 deletions
diff --git a/textproc/p5-XML-Mini/Makefile b/textproc/p5-XML-Mini/Makefile
new file mode 100644
index 000000000000..a9d56509279d
--- /dev/null
+++ b/textproc/p5-XML-Mini/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-XML-Mini
+# Date created: 12-JUL-2006
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Mini
+PORTVERSION= 1.2.8
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Perl implementation of the XML::Mini XML create/parse interface
+
+PERL_CONFIGURE= yes
+
+RUN_DEPENDS+= p5-Text-Balanced>=0.0:${PORTSDIR}/textproc/p5-Text-Balanced
+
+MAN3= XML::Mini.3 XML::Mini::Document.3 XML::Mini::Element.3 \
+ XML::Mini::Element::CData.3 XML::Mini::Element::Comment.3 \
+ XML::Mini::Element::DocType.3 XML::Mini::Element::Entity.3 \
+ XML::Mini::Element::Header.3 XML::Mini::Node.3 \
+ XML::Mini::TreeComponent.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Mini/distinfo b/textproc/p5-XML-Mini/distinfo
new file mode 100644
index 000000000000..3038364fe746
--- /dev/null
+++ b/textproc/p5-XML-Mini/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Mini-1.2.8.tar.gz) = ca3a9dffd09f6675c4ed5fd9318ec8fa
+SHA256 (XML-Mini-1.2.8.tar.gz) = 9e66e218796c503da2fe47b0670581880121427860faa58a7d2c704ad02ccf51
+SIZE (XML-Mini-1.2.8.tar.gz) = 35349
diff --git a/textproc/p5-XML-Mini/pkg-descr b/textproc/p5-XML-Mini/pkg-descr
new file mode 100644
index 000000000000..3bd4a70f8e23
--- /dev/null
+++ b/textproc/p5-XML-Mini/pkg-descr
@@ -0,0 +1,6 @@
+XML::Mini is a set of Perl classes that allow you to access XML data and
+create valid XML output with a tree-based hierarchy of elements.
+
+XML::Mini does not require any external libraries or modules and is pure Perl.
+If available, XML::Mini will use the Text::Balanced module in order to escape
+limitations of the regex-only approach (eg "cross-nested" tag parsing).
diff --git a/textproc/p5-XML-Mini/pkg-plist b/textproc/p5-XML-Mini/pkg-plist
new file mode 100644
index 000000000000..3ff8c9598e80
--- /dev/null
+++ b/textproc/p5-XML-Mini/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/XML/Mini.pm
+%%SITE_PERL%%/XML/Mini/Document.pm
+%%SITE_PERL%%/XML/Mini/Element.pm
+%%SITE_PERL%%/XML/Mini/Element/CData.pm
+%%SITE_PERL%%/XML/Mini/Element/Comment.pm
+%%SITE_PERL%%/XML/Mini/Element/DocType.pm
+%%SITE_PERL%%/XML/Mini/Element/Entity.pm
+%%SITE_PERL%%/XML/Mini/Element/Header.pm
+%%SITE_PERL%%/XML/Mini/Node.pm
+%%SITE_PERL%%/XML/Mini/TreeComponent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Mini/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Mini
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrm %%SITE_PERL%%/XML/Mini/Element
+@dirrm %%SITE_PERL%%/XML/Mini
+@dirrmtry %%SITE_PERL%%/XML