aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Parser-EasyTree
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-24 08:22:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-24 08:22:37 +0000
commitc60be643237a730419731b35c4c4d5c371213a68 (patch)
tree6c5635e7003d895ea0e62b18b8804ff9ed0dfac7 /textproc/p5-XML-Parser-EasyTree
parent239d01c2309c65ba492389c99837e6f511b23ffc (diff)
downloadports-c60be643237a730419731b35c4c4d5c371213a68.tar.gz
ports-c60be643237a730419731b35c4c4d5c371213a68.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Parser-EasyTree')
-rw-r--r--textproc/p5-XML-Parser-EasyTree/Makefile26
-rw-r--r--textproc/p5-XML-Parser-EasyTree/distinfo1
-rw-r--r--textproc/p5-XML-Parser-EasyTree/pkg-descr5
-rw-r--r--textproc/p5-XML-Parser-EasyTree/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/p5-XML-Parser-EasyTree/Makefile b/textproc/p5-XML-Parser-EasyTree/Makefile
new file mode 100644
index 000000000000..d1e2336f5659
--- /dev/null
+++ b/textproc/p5-XML-Parser-EasyTree/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: XML::Parser::EasyTree
+# Date created: Oct 24, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Parser-EasyTree
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Easier tree style for XML::Parser
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Parser::EasyTree.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Parser-EasyTree/distinfo b/textproc/p5-XML-Parser-EasyTree/distinfo
new file mode 100644
index 000000000000..8470614930f3
--- /dev/null
+++ b/textproc/p5-XML-Parser-EasyTree/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Parser-EasyTree-0.01.tar.gz) = f5221737a572a97b3187dade3a1f4191
diff --git a/textproc/p5-XML-Parser-EasyTree/pkg-descr b/textproc/p5-XML-Parser-EasyTree/pkg-descr
new file mode 100644
index 000000000000..af99256301b0
--- /dev/null
+++ b/textproc/p5-XML-Parser-EasyTree/pkg-descr
@@ -0,0 +1,5 @@
+XML::Parser::EasyTree adds a new "built-in" style called "EasyTree" to
+XML::Parser. Like XML::Parser's "Tree" style, setting this style causes
+the parser to build a lightweight tree structure representing the XML
+document. This structure is, at least in this author's opinion, easier to
+work with than the one created by the built-in style.
diff --git a/textproc/p5-XML-Parser-EasyTree/pkg-plist b/textproc/p5-XML-Parser-EasyTree/pkg-plist
new file mode 100644
index 000000000000..456e6a400e2a
--- /dev/null
+++ b/textproc/p5-XML-Parser-EasyTree/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/EasyTree/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser/EasyTree
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Parser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+%%SITE_PERL%%/XML/Parser/EasyTree.pm
+@unexec rmdir %D/%%SITE_PERL%%/XML/Parser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true