aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX-Base
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 06:13:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 06:13:57 +0000
commit6bcd0ca16e952344ccf9c551966f4a0d38f46160 (patch)
tree17be8dadc0a0ff134bf82ac74f0f993643f56a06 /textproc/p5-XML-SAX-Base
parent42c19a6d624b16fbc3fdbb4291f92abbf5b08787 (diff)
downloadports-6bcd0ca16e952344ccf9c551966f4a0d38f46160.tar.gz
ports-6bcd0ca16e952344ccf9c551966f4a0d38f46160.zip
Notes
Diffstat (limited to 'textproc/p5-XML-SAX-Base')
-rw-r--r--textproc/p5-XML-SAX-Base/Makefile24
-rw-r--r--textproc/p5-XML-SAX-Base/distinfo1
-rw-r--r--textproc/p5-XML-SAX-Base/pkg-comment1
-rw-r--r--textproc/p5-XML-SAX-Base/pkg-descr8
-rw-r--r--textproc/p5-XML-SAX-Base/pkg-plist8
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/p5-XML-SAX-Base/Makefile b/textproc/p5-XML-SAX-Base/Makefile
new file mode 100644
index 000000000000..434f58fd4b5b
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: XML::SAX::Base
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SAX-Base
+PORTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= XML
+MASTER_SITE_SUBDIR= ../by-authors/id/K/KH/KHAMPTON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::SAX::Exception.3 \
+ XML::SAX::Base.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAX-Base/distinfo b/textproc/p5-XML-SAX-Base/distinfo
new file mode 100644
index 000000000000..85c585a1c9f0
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/distinfo
@@ -0,0 +1 @@
+MD5 (XML-SAX-Base-1.04.tar.gz) = e4d248e8ac1811a5db0aa043c56af612
diff --git a/textproc/p5-XML-SAX-Base/pkg-comment b/textproc/p5-XML-SAX-Base/pkg-comment
new file mode 100644
index 000000000000..aaf8d7556bf8
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/pkg-comment
@@ -0,0 +1 @@
+Base class SAX Drivers and Filters
diff --git a/textproc/p5-XML-SAX-Base/pkg-descr b/textproc/p5-XML-SAX-Base/pkg-descr
new file mode 100644
index 000000000000..9c4cd9b97988
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/pkg-descr
@@ -0,0 +1,8 @@
+This module has a very simple task - to be a base class for PerlSAX
+drivers and filters. It's default behaviour is to pass the input directly
+to the output unchanged. It can be useful to use this module as a base class
+so you don't have to, for example, implement the characters() callback.
+
+WWW: http://search.cpan.org/search?dist=XML-SAX-Base
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/textproc/p5-XML-SAX-Base/pkg-plist b/textproc/p5-XML-SAX-Base/pkg-plist
new file mode 100644
index 000000000000..f001db4efdb4
--- /dev/null
+++ b/textproc/p5-XML-SAX-Base/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Base/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Exception.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/Base 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true