aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-01-28 12:10:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-01-28 12:10:37 +0000
commite2f9b3f65fb46ddbe0d469a33b04e8088d162010 (patch)
tree1ff3431de253c3c41df5e91b48d347d9e9ce81b9 /textproc/p5-XML-SAX/Makefile
parentc9a94b6d817bff1bfef241e75cb638e40dfd4d14 (diff)
downloadports-e2f9b3f65fb46ddbe0d469a33b04e8088d162010.tar.gz
ports-e2f9b3f65fb46ddbe0d469a33b04e8088d162010.zip
Notes
Diffstat (limited to 'textproc/p5-XML-SAX/Makefile')
-rw-r--r--textproc/p5-XML-SAX/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
index 44462d548a58..93127e5e147a 100644
--- a/textproc/p5-XML-SAX/Makefile
+++ b/textproc/p5-XML-SAX/Makefile
@@ -6,23 +6,30 @@
#
PORTNAME= XML-SAX
-PORTVERSION= 0.03
+PORTVERSION= 0.05
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
-MAN3= XML::SAX.3 XML::SAX::Base.3 XML::SAX::Exception.3 \
- XML::SAX::ParserFactory.3 XML::SAX::PurePerl.3 \
- XML::SAX::PurePerl::Reader.3
+MAN3= XML::SAX.3 XML::SAX::Base.3 XML::SAX::DocumentLocator.3 \
+ XML::SAX::Exception.3 XML::SAX::ParserFactory.3 \
+ XML::SAX::PurePerl.3 XML::SAX::PurePerl::Reader.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-configure:
+# dirty hack to deceive irritable pod2man
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 -lax/;' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>