aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-27 19:46:54 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-27 19:46:54 +0000
commitc585f3b100527b4f310833e75477118b4aa39043 (patch)
tree223c2ac2abeab74cc80703c118fd6665f04b92f1 /textproc/p5-XML-SAX/Makefile
parentc36dec03733276a21e2b31adfa36143f98aa969a (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-SAX/Makefile')
-rw-r--r--textproc/p5-XML-SAX/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
index c15da34ee832..b676b948c4d0 100644
--- a/textproc/p5-XML-SAX/Makefile
+++ b/textproc/p5-XML-SAX/Makefile
@@ -25,6 +25,21 @@ MAN3= XML::SAX.3 XML::SAX::DocumentLocator.3 XML::SAX::Intro.3 \
XML::SAX::ParserFactory.3 XML::SAX::PurePerl.3 \
XML::SAX::PurePerl::Reader.3
+OPTIONS= WRITE_INI_OK "Alter ParserDetails.ini with relevant information" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_WRITE_INI_OK)
+WRITE_INI_OK= 1
+.else
+WRITE_INI_OK= 0
+.endif
+
+post-patch:
+# dirty hack to stop asking for confirmation to alter ParserDetails.ini
+ @${REINPLACE_CMD} -e 's/%%WRITE_INI_OK%%/${WRITE_INI_OK}/' \
+ ${WRKSRC}/Makefile.PL
+
post-configure:
# dirty hack to deceive irritable pod2man
@${PERL} -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile