aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-STX/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 03:52:41 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 03:52:41 +0000
commitfb2d5da4ebc1084c623330fb16bdcba15bb94569 (patch)
tree36786afbdfb0f0368eaca996fb006935240c6493 /textproc/p5-XML-STX/Makefile
parent641aebe3adc2c952a71a943fa648da6f4daf0b14 (diff)
downloadports-fb2d5da4ebc1084c623330fb16bdcba15bb94569.tar.gz
ports-fb2d5da4ebc1084c623330fb16bdcba15bb94569.zip
Notes
Diffstat (limited to 'textproc/p5-XML-STX/Makefile')
-rw-r--r--textproc/p5-XML-STX/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/textproc/p5-XML-STX/Makefile b/textproc/p5-XML-STX/Makefile
index da7f9f29ee33..d78d8afb27f5 100644
--- a/textproc/p5-XML-STX/Makefile
+++ b/textproc/p5-XML-STX/Makefile
@@ -18,12 +18,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure patch
-MAN3= XML::STX.3 XML::STX::Base.3 XML::STX::Buffer.3 \
- XML::STX::Functions.3 XML::STX::Parser.3 XML::STX::Runtime.3 \
- XML::STX::STXPath.3 XML::STX::Stylesheet.3 XML::STX::TrAX.3 \
- XML::STX::Writer.3
-
-NO_STAGE= yes
post-extract:
@${MKDIR} ${WRKSRC}/scripts
@${MV} ${WRKSRC}/stx*.pl ${WRKSRC}/scripts
@@ -37,11 +31,11 @@ post-configure:
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing additional documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>