aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Smart
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-13 10:56:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-13 10:56:57 +0000
commit5fabb2872afd81956988b09992b3a434d5282823 (patch)
treec9b265e489ba91c94c75e98460e347239fdfaa1e /textproc/p5-XML-Smart
parent5e6da598a61948368d1aea633235013182d8effb (diff)
downloadports-5fabb2872afd81956988b09992b3a434d5282823.tar.gz
ports-5fabb2872afd81956988b09992b3a434d5282823.zip
Notes
Diffstat (limited to 'textproc/p5-XML-Smart')
-rw-r--r--textproc/p5-XML-Smart/Makefile25
-rw-r--r--textproc/p5-XML-Smart/distinfo1
-rw-r--r--textproc/p5-XML-Smart/pkg-descr18
-rw-r--r--textproc/p5-XML-Smart/pkg-plist13
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/p5-XML-Smart/Makefile b/textproc/p5-XML-Smart/Makefile
new file mode 100644
index 000000000000..c3e10b5c84ee
--- /dev/null
+++ b/textproc/p5-XML-Smart/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-XML-Smart
+# Date created: October 10th 2000
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+
+PORTNAME= XML-Smart
+PORTVERSION= 1.4
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A Smart, easy and powerful way to access/create XML files/data
+
+BUILD_DEPENDS= ${SITE_PERL}/Object/MultiType.pm:${PORTSDIR}/devel/p5-Object-MultiType \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= XML::Smart.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Smart/distinfo b/textproc/p5-XML-Smart/distinfo
new file mode 100644
index 000000000000..e131fc97d8b3
--- /dev/null
+++ b/textproc/p5-XML-Smart/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Smart-1.4.tar.gz) = 35031a3525508809a76bbc2dc876f0fb
diff --git a/textproc/p5-XML-Smart/pkg-descr b/textproc/p5-XML-Smart/pkg-descr
new file mode 100644
index 000000000000..ee31028bd1ad
--- /dev/null
+++ b/textproc/p5-XML-Smart/pkg-descr
@@ -0,0 +1,18 @@
+This module has an easy way to access/create XML data. It's based on the HASH
+tree that is made of the XML data, and enable a dynamic access to it with the
+Perl syntax for Hashe and Array, without needing to care if you have a Hashe or
+an Array in the tree. In other words, each point in the tree work as a Hash and
+an Array at the same time!
+
+The module alson handle automatically binary data (encoding/decoding to/from
+base64), CDATA (like contents with <tags>) and Unicode. It can be used to
+create XML files, load XML from the Web (just pasting an URL as a file path)
+and it has an easy way to send XML data through socket, just adding the length
+of the data in the <?xml?> header.
+
+You can use XML::Smart with XML::Parser, or with the 2 standart parsers of
+XML::Smart:
+
+WWW: http://search.cpan.org/dist/XML-Smart/
+
+Author: Graciliano M. P. <gm@virtuasites.com.br>
diff --git a/textproc/p5-XML-Smart/pkg-plist b/textproc/p5-XML-Smart/pkg-plist
new file mode 100644
index 000000000000..212baadefeca
--- /dev/null
+++ b/textproc/p5-XML-Smart/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/XML/Smart.pm
+%%SITE_PERL%%/XML/Smart/Base64.pm
+%%SITE_PERL%%/XML/Smart/Data.pm
+%%SITE_PERL%%/XML/Smart/HTMLParser.pm
+%%SITE_PERL%%/XML/Smart/Parser.pm
+%%SITE_PERL%%/XML/Smart/Tie.pm
+%%SITE_PERL%%/XML/Smart/Tree.pm
+%%SITE_PERL%%/XML/Smart/XPath.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Smart/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Smart
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@dirrm %%SITE_PERL%%/XML/Smart
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true