aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Twig/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-21 09:26:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-21 09:26:30 +0000
commit24bc5ff2d3f57ad909140629ec9c25f7a88995ca (patch)
treea585fe01defc75c471259c8cc626330293283fba /textproc/p5-XML-Twig/Makefile
parent95bc3fbcc47f2ae6a4e0f899bb0e69fca6291a2b (diff)
Notes
Diffstat (limited to 'textproc/p5-XML-Twig/Makefile')
-rw-r--r--textproc/p5-XML-Twig/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/textproc/p5-XML-Twig/Makefile b/textproc/p5-XML-Twig/Makefile
index edd930c1f20c..d7d4e7de69d1 100644
--- a/textproc/p5-XML-Twig/Makefile
+++ b/textproc/p5-XML-Twig/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML-Twig
-PORTVERSION= 3.09
+PORTVERSION= 3.15
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@@ -18,10 +18,27 @@ COMMENT= Process huge XML documents by chunks via a tree interface
# On Perl < 5.8.0, XML::Twig has a further optional dependency on WeakRef.
# However, WeakRef needs Perl 5.005_55.
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
+ ${SITE_PERL}/XML/Handler/YAWriter.pm:${PORTSDIR}/textproc/p5-XML-Handler-YAWriter \
+ ${SITE_PERL}/XML/SAX/Writer.pm:${PORTSDIR}/textproc/p5-XML-SAX-Writer \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
+MAN1= xml_grep.1 xml_pp.1 xml_spellcheck.1
MAN3= XML::Twig.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /warnings/' \
+ ${WRKSRC}/Twig/XPath.pm
+.endif
+
+.include <bsd.port.post.mk>