aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XPathEngine
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-11 14:14:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-11 14:14:26 +0000
commit108d2727e47224c7771e112524e104093d3d76be (patch)
tree9b362b10349a1f6e309264ad7dddf3e8548da908 /textproc/p5-XML-XPathEngine
parent1c4dd070c2e83442a2e8f2c939fefb7c851e554b (diff)
downloadports-108d2727e47224c7771e112524e104093d3d76be.tar.gz
ports-108d2727e47224c7771e112524e104093d3d76be.zip
Notes
Diffstat (limited to 'textproc/p5-XML-XPathEngine')
-rw-r--r--textproc/p5-XML-XPathEngine/Makefile24
-rw-r--r--textproc/p5-XML-XPathEngine/distinfo3
-rw-r--r--textproc/p5-XML-XPathEngine/pkg-descr17
-rw-r--r--textproc/p5-XML-XPathEngine/pkg-plist17
4 files changed, 61 insertions, 0 deletions
diff --git a/textproc/p5-XML-XPathEngine/Makefile b/textproc/p5-XML-XPathEngine/Makefile
new file mode 100644
index 000000000000..4752fdeb2940
--- /dev/null
+++ b/textproc/p5-XML-XPathEngine/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-XML-XPathEngine
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-XPathEngine
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A re-usable XPath engine for DOM-like trees
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::XPathEngine.3 XML::XPathEngine::Boolean.3 \
+ XML::XPathEngine::Literal.3 XML::XPathEngine::NodeSet.3 \
+ XML::XPathEngine::Number.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-XPathEngine/distinfo b/textproc/p5-XML-XPathEngine/distinfo
new file mode 100644
index 000000000000..b1785d504041
--- /dev/null
+++ b/textproc/p5-XML-XPathEngine/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-XPathEngine-0.03.tar.gz) = 05986328f5d55a2fa8b7d50043fcb7da
+SHA256 (XML-XPathEngine-0.03.tar.gz) = 99956d491b44d6e02ef701585d2368fde91fca91d834454f493b45fde61bf5c4
+SIZE (XML-XPathEngine-0.03.tar.gz) = 22358
diff --git a/textproc/p5-XML-XPathEngine/pkg-descr b/textproc/p5-XML-XPathEngine/pkg-descr
new file mode 100644
index 000000000000..90af033b3b9f
--- /dev/null
+++ b/textproc/p5-XML-XPathEngine/pkg-descr
@@ -0,0 +1,17 @@
+This module provides an XPath engine, that can be re-used by other
+module/classes that implement trees.
+
+In order to use the XPath engine, nodes in the user module need to
+mimick DOM nodes. The degree of similitude between the user tree and a
+DOM dictates how much of the XPath features can be used. A module
+implementing all of the DOM should be able to use this module very
+easily (you might need to add the cmp method on nodes in order to get
+ordered result sets).
+
+This code is a more or less direct copy of the XML::XPath module by
+Matt Sergeant. I only removed the XML processing part to remove the
+dependency on XML::Parser, applied a couple of patches, renamed a
+whole lot of methods to make Pod::Coverage happy, and changed the docs.
+
+Author: Michel Rodriguez, <mirod@cpan.org>
+WWW: http://search.cpan.org/dist/XML-XPathEngine/
diff --git a/textproc/p5-XML-XPathEngine/pkg-plist b/textproc/p5-XML-XPathEngine/pkg-plist
new file mode 100644
index 000000000000..0ab4189685e4
--- /dev/null
+++ b/textproc/p5-XML-XPathEngine/pkg-plist
@@ -0,0 +1,17 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/XPathEngine/.packlist
+%%SITE_PERL%%/XML/XPathEngine.pm
+%%SITE_PERL%%/XML/XPathEngine/Boolean.pm
+%%SITE_PERL%%/XML/XPathEngine/Expr.pm
+%%SITE_PERL%%/XML/XPathEngine/Function.pm
+%%SITE_PERL%%/XML/XPathEngine/Literal.pm
+%%SITE_PERL%%/XML/XPathEngine/LocationPath.pm
+%%SITE_PERL%%/XML/XPathEngine/NodeSet.pm
+%%SITE_PERL%%/XML/XPathEngine/Number.pm
+%%SITE_PERL%%/XML/XPathEngine/Root.pm
+%%SITE_PERL%%/XML/XPathEngine/Step.pm
+%%SITE_PERL%%/XML/XPathEngine/Variable.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/XPathEngine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/XPathEngine
+@dirrmtry %%SITE_PERL%%/XML