aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XPathEngine
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-09 03:03:55 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-09 03:03:55 +0000
commit0d707c32c745665ead3730e9b8df73306d549c9d (patch)
tree9f480516ed3de35641a55fcc16edcc4cdd8168fa /textproc/p5-XML-XPathEngine
parentd31e23eb5cd76f284ecf509cd8789edd1cb3acb7 (diff)
downloadports-0d707c32c745665ead3730e9b8df73306d549c9d.tar.gz
ports-0d707c32c745665ead3730e9b8df73306d549c9d.zip
Notes
Diffstat (limited to 'textproc/p5-XML-XPathEngine')
-rw-r--r--textproc/p5-XML-XPathEngine/Makefile5
-rw-r--r--textproc/p5-XML-XPathEngine/files/extra-lib-XML-XPathEngine.pm30
2 files changed, 34 insertions, 1 deletions
diff --git a/textproc/p5-XML-XPathEngine/Makefile b/textproc/p5-XML-XPathEngine/Makefile
index 802f0011b0ed..7be89fe41fd1 100644
--- a/textproc/p5-XML-XPathEngine/Makefile
+++ b/textproc/p5-XML-XPathEngine/Makefile
@@ -24,7 +24,10 @@ MAN3= XML::XPathEngine.3 XML::XPathEngine::Boolean.3 \
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+EXTRA_PATCHES= ${PATCHDIR}/extra-*
+
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if /^use warnings/' ${WRKSRC}/Makefile.PL
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-XPathEngine/files/extra-lib-XML-XPathEngine.pm b/textproc/p5-XML-XPathEngine/files/extra-lib-XML-XPathEngine.pm
new file mode 100644
index 000000000000..0eeff6ca83d5
--- /dev/null
+++ b/textproc/p5-XML-XPathEngine/files/extra-lib-XML-XPathEngine.pm
@@ -0,0 +1,30 @@
+--- lib/XML/XPathEngine.pm.orig Tue Aug 8 22:49:51 2006
++++ lib/XML/XPathEngine.pm Tue Aug 8 22:50:29 2006
+@@ -1,27 +1,10 @@
+ package XML::XPathEngine;
+
+-use warnings;
+ use strict;
+
+-use vars qw($VERSION $AUTOLOAD $revision);
+-
+ $VERSION = '0.03';
+ $XML::XPathEngine::Namespaces = 0;
+ $XML::XPathEngine::DEBUG = 0;
+-
+-use vars qw/
+- $NCName
+- $QName
+- $NCWild
+- $QNWild
+- $NUMBER_RE
+- $NODE_TYPE
+- $AXIS_NAME
+- %AXES
+- $LITERAL
+- $REGEXP_RE
+- $REGEXP_MOD_RE
+- %CACHE/;
+
+ use XML::XPathEngine::Step;
+ use XML::XPathEngine::Expr;