aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XSLT
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 02:11:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 02:11:35 +0000
commitdc17d3ead2235a6561394e9dabff4accdedb9be0 (patch)
treea44268b910bf356a14236b861b504c40507b88e3 /textproc/p5-XML-XSLT
parent3f9a715bc2d7e754f98f7783337eab4296830a74 (diff)
downloadports-dc17d3ead2235a6561394e9dabff4accdedb9be0.tar.gz
ports-dc17d3ead2235a6561394e9dabff4accdedb9be0.zip
Notes
Diffstat (limited to 'textproc/p5-XML-XSLT')
-rw-r--r--textproc/p5-XML-XSLT/Makefile25
-rw-r--r--textproc/p5-XML-XSLT/distinfo1
-rw-r--r--textproc/p5-XML-XSLT/pkg-comment1
-rw-r--r--textproc/p5-XML-XSLT/pkg-descr4
-rw-r--r--textproc/p5-XML-XSLT/pkg-plist4
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-XML-XSLT/Makefile b/textproc/p5-XML-XSLT/Makefile
new file mode 100644
index 000000000000..efb100582688
--- /dev/null
+++ b/textproc/p5-XML-XSLT/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-XML-XSLT
+# Date created: May 26 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-XSLT
+PORTVERSION= 0.21
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XML::XSLT.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-XSLT/distinfo b/textproc/p5-XML-XSLT/distinfo
new file mode 100644
index 000000000000..96003bf230e7
--- /dev/null
+++ b/textproc/p5-XML-XSLT/distinfo
@@ -0,0 +1 @@
+MD5 (XML-XSLT-0.21.tar.gz) = 477253ddcb44c23381754e41c796e107
diff --git a/textproc/p5-XML-XSLT/pkg-comment b/textproc/p5-XML-XSLT/pkg-comment
new file mode 100644
index 000000000000..d4fc667fb113
--- /dev/null
+++ b/textproc/p5-XML-XSLT/pkg-comment
@@ -0,0 +1 @@
+XML::XSLT - A perl module for processing XSLT
diff --git a/textproc/p5-XML-XSLT/pkg-descr b/textproc/p5-XML-XSLT/pkg-descr
new file mode 100644
index 000000000000..2eaabb0fcfc6
--- /dev/null
+++ b/textproc/p5-XML-XSLT/pkg-descr
@@ -0,0 +1,4 @@
+This module implements the W3C's XSLT specification. The goal
+is full implementation of this spec, but it isn't yet. However,
+it already works well. Below is given the set of working xslt
+commands.
diff --git a/textproc/p5-XML-XSLT/pkg-plist b/textproc/p5-XML-XSLT/pkg-plist
new file mode 100644
index 000000000000..7dd8f7e18a43
--- /dev/null
+++ b/textproc/p5-XML-XSLT/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/XML/XSLT.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XSLT/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XSLT
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true