aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-YAML-Shell
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-05-24 21:49:48 +0000
committerSteve Wills <swills@FreeBSD.org>2011-05-24 21:49:48 +0000
commitfcb7edb495320777ad7966d809d63f9cd75b70cb (patch)
treee4d4b1abda14d21cb0eb84ca56ff89d9fc5d7f3d /textproc/p5-YAML-Shell
parentf213e60164932ee43964509ba4f29eb292f96be2 (diff)
This program is designed to let you play with the Perl YAML modules in an
interactive way. When you to type in Perl, you get back YAML. And vice versa. WWW: http://search.cpan.org/dist/YAML-Shell/
Notes
Notes: svn path=/head/; revision=274590
Diffstat (limited to 'textproc/p5-YAML-Shell')
-rw-r--r--textproc/p5-YAML-Shell/Makefile27
-rw-r--r--textproc/p5-YAML-Shell/distinfo2
-rw-r--r--textproc/p5-YAML-Shell/pkg-descr4
-rw-r--r--textproc/p5-YAML-Shell/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/p5-YAML-Shell/Makefile b/textproc/p5-YAML-Shell/Makefile
new file mode 100644
index 000000000000..3f31d7f2e49b
--- /dev/null
+++ b/textproc/p5-YAML-Shell/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-YAML-Shell
+# Date created: 2011-05-24
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= YAML-Shell
+PORTVERSION= 0.60
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:INGY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= The YAML Test Shell
+
+BUILD_DEPENDS= p5-YAML>=0.67:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= p5-YAML>=0.67:${PORTSDIR}/textproc/p5-YAML
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN1= ysh.1
+MAN3= YAML::Shell.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-YAML-Shell/distinfo b/textproc/p5-YAML-Shell/distinfo
new file mode 100644
index 000000000000..cab6f65a4b27
--- /dev/null
+++ b/textproc/p5-YAML-Shell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (YAML-Shell-0.60.tar.gz) = 947c8397b672ef8bcdf91727eac3abf84ab51da4835d2bf73ff70f25d81d8053
+SIZE (YAML-Shell-0.60.tar.gz) = 15793
diff --git a/textproc/p5-YAML-Shell/pkg-descr b/textproc/p5-YAML-Shell/pkg-descr
new file mode 100644
index 000000000000..c42672e28f8b
--- /dev/null
+++ b/textproc/p5-YAML-Shell/pkg-descr
@@ -0,0 +1,4 @@
+This program is designed to let you play with the Perl YAML modules in an
+interactive way. When you to type in Perl, you get back YAML. And vice versa.
+
+WWW: http://search.cpan.org/dist/YAML-Shell/
diff --git a/textproc/p5-YAML-Shell/pkg-plist b/textproc/p5-YAML-Shell/pkg-plist
new file mode 100644
index 000000000000..6eda1960c3b4
--- /dev/null
+++ b/textproc/p5-YAML-Shell/pkg-plist
@@ -0,0 +1,6 @@
+bin/ysh
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAML/Shell/.packlist
+%%SITE_PERL%%/YAML/Shell.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/YAML/Shell
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/YAML
+@dirrmtry %%SITE_PERL%%/YAML