aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-YAML-Syck/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-28 09:46:03 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-28 09:46:03 +0000
commitf1f8252ece888cd6a02555fe94af1ce1e9703660 (patch)
tree0242bd8ad8492bca2a08588f0cd820e91fdba496 /textproc/p5-YAML-Syck/Makefile
parent9220708e45801725df4faba59419d36b5910081f (diff)
Notes
Diffstat (limited to 'textproc/p5-YAML-Syck/Makefile')
-rw-r--r--textproc/p5-YAML-Syck/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-YAML-Syck/Makefile b/textproc/p5-YAML-Syck/Makefile
new file mode 100644
index 000000000000..954dfd086239
--- /dev/null
+++ b/textproc/p5-YAML-Syck/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-YAML-Syck
+# Date created: 28 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= YAML-Syck
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= YAML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fast, lightweight YAML loader and dumper
+
+PERL_CONFIGURE= yes
+
+MAN3= YAML::Syck.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>