aboutsummaryrefslogtreecommitdiff
path: root/textproc/pandoc/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-02-11 17:21:55 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-02-11 17:21:55 +0000
commit86d87c23aa0f5a2f987af12a00675814254116fb (patch)
tree55d570aadb4bb0d54f692eb18289d1740d12b35d /textproc/pandoc/Makefile
parent183cdb8416a9780c9cbc913119bd414f5065a464 (diff)
downloadports-86d87c23aa0f5a2f987af12a00675814254116fb.tar.gz
ports-86d87c23aa0f5a2f987af12a00675814254116fb.zip
Notes
Diffstat (limited to 'textproc/pandoc/Makefile')
-rw-r--r--textproc/pandoc/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/textproc/pandoc/Makefile b/textproc/pandoc/Makefile
new file mode 100644
index 000000000000..9cc9d9d96a52
--- /dev/null
+++ b/textproc/pandoc/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pandoc
+# Date created: 9 February 2007
+# Whom: John MacFarlane <jgm@berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pandoc
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+MASTER_SITES= http://pandoc.googlecode.com/files/
+DISTNAME= pandoc-${PORTVERSION}
+
+MAINTAINER= jgm@berkeley.edu
+COMMENT= A general markup converter
+
+BUILD_DEPENDS= ghc>=6.4:${PORTSDIR}/lang/ghc
+
+MANCOMPRESSED= no
+MAN1= pandoc.1 markdown2pdf.1 html2markdown.1 hsmarkdown.1
+
+USE_GMAKE= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/pandoc bin/markdown2pdf bin/html2markdown bin/hsmarkdown
+PORTDOCS= BUGS README README.html
+SCRIPTS= hsmarkdown html2markdown markdown2pdf
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dist/build/pandoc/pandoc ${PREFIX}/bin
+.for script in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
+.for man in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>