aboutsummaryrefslogtreecommitdiff
path: root/textproc/pandoc
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-02-11 17:21:55 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-02-11 17:21:55 +0000
commit86d87c23aa0f5a2f987af12a00675814254116fb (patch)
tree55d570aadb4bb0d54f692eb18289d1740d12b35d /textproc/pandoc
parent183cdb8416a9780c9cbc913119bd414f5065a464 (diff)
Pandoc is a command-line tool for converting from one markup format
to another. It can read markdown and (subsets of) reStructuredText, HTML, and LaTeX, and it can write markdown, reStructuredText, HTML, LaTeX, DocBook, RTF, and S5 HTML slide shows. Pandoc extends standard markdown syntax with footnotes, embedded LaTeX, and other features. A compatibility mode is provided for those who need a drop-in replacement for Markdown.pl. Included wrapper scripts make it easy to convert markdown documents to PDFs and to convert web pages to markdown documents. In contrast to existing tools for converting markdown to HTML, which use regex substitutions, pandoc has a modular design: it consists of a set of readers, which parse text in a given format and produce a native representation of the document, and a set of writers, which convert this native representation into a target format. Thus, adding an input or output format requires only adding a reader or writer. WWW: http://sophos.berkeley.edu/macfarlane/pandoc/ PR: ports/109028 Submitted by: John MacFarlane <jgm at berkeley.edu> Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=184899
Diffstat (limited to 'textproc/pandoc')
-rw-r--r--textproc/pandoc/Makefile44
-rw-r--r--textproc/pandoc/distinfo3
-rw-r--r--textproc/pandoc/pkg-descr19
3 files changed, 66 insertions, 0 deletions
diff --git a/textproc/pandoc/Makefile b/textproc/pandoc/Makefile
new file mode 100644
index 000000000000..9cc9d9d96a52
--- /dev/null
+++ b/textproc/pandoc/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pandoc
+# Date created: 9 February 2007
+# Whom: John MacFarlane <jgm@berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pandoc
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+MASTER_SITES= http://pandoc.googlecode.com/files/
+DISTNAME= pandoc-${PORTVERSION}
+
+MAINTAINER= jgm@berkeley.edu
+COMMENT= A general markup converter
+
+BUILD_DEPENDS= ghc>=6.4:${PORTSDIR}/lang/ghc
+
+MANCOMPRESSED= no
+MAN1= pandoc.1 markdown2pdf.1 html2markdown.1 hsmarkdown.1
+
+USE_GMAKE= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/pandoc bin/markdown2pdf bin/html2markdown bin/hsmarkdown
+PORTDOCS= BUGS README README.html
+SCRIPTS= hsmarkdown html2markdown markdown2pdf
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dist/build/pandoc/pandoc ${PREFIX}/bin
+.for script in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
+.for man in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/pandoc/distinfo b/textproc/pandoc/distinfo
new file mode 100644
index 000000000000..b059d16ceba4
--- /dev/null
+++ b/textproc/pandoc/distinfo
@@ -0,0 +1,3 @@
+MD5 (pandoc-0.3.tar.gz) = 08ea5da564b721bd3cd52eee316143a1
+SHA256 (pandoc-0.3.tar.gz) = b010436d325c8ec67e2f9c238474089f76c895bec3ef19ca13c82da5860a4b05
+SIZE (pandoc-0.3.tar.gz) = 243335
diff --git a/textproc/pandoc/pkg-descr b/textproc/pandoc/pkg-descr
new file mode 100644
index 000000000000..6638e6cd4829
--- /dev/null
+++ b/textproc/pandoc/pkg-descr
@@ -0,0 +1,19 @@
+Pandoc is a command-line tool for converting from one markup format
+to another. It can read markdown and (subsets of) reStructuredText,
+HTML, and LaTeX, and it can write markdown, reStructuredText, HTML,
+LaTeX, DocBook, RTF, and S5 HTML slide shows.
+
+Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
+and other features. A compatibility mode is provided for those who
+need a drop-in replacement for Markdown.pl. Included wrapper scripts
+make it easy to convert markdown documents to PDFs and to convert web
+pages to markdown documents.
+
+In contrast to existing tools for converting markdown to HTML, which
+use regex substitutions, pandoc has a modular design: it consists of a
+set of readers, which parse text in a given format and produce a native
+representation of the document, and a set of writers, which convert
+this native representation into a target format. Thus, adding an input
+or output format requires only adding a reader or writer.
+
+WWW: http://sophos.berkeley.edu/macfarlane/pandoc/