aboutsummaryrefslogtreecommitdiff
path: root/textproc/par
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2014-02-10 21:31:14 +0000
committerMark Murray <markm@FreeBSD.org>2014-02-10 21:31:14 +0000
commitf28a05d93dd691e2424cd38ade561069ffbf78ed (patch)
tree00d4ab8c89213f04ed79fc5a3e03171fdbba978f /textproc/par
parentdb451d5c84d99f956c9bfd2893492b38072eee17 (diff)
Notes
Diffstat (limited to 'textproc/par')
-rw-r--r--textproc/par/Makefile10
-rw-r--r--textproc/par/files/patch-par.c4
-rw-r--r--textproc/par/files/patch-protoMakefile (renamed from textproc/par/files/patch-aa)8
-rw-r--r--textproc/par/files/patch-reformat.c11
4 files changed, 22 insertions, 11 deletions
diff --git a/textproc/par/Makefile b/textproc/par/Makefile
index 630b148190c2..24142b1d5896 100644
--- a/textproc/par/Makefile
+++ b/textproc/par/Makefile
@@ -8,21 +8,21 @@ CATEGORIES= textproc
MASTER_SITES= http://www.nicemice.net/par/
DISTNAME= Par${PORTVERSION:S|.||}
-MAINTAINER= mark@grondar.za
+MAINTAINER= markm@FreeBSD.org
COMMENT= Paragraph reformatter for email
CONFLICTS= quake-par-[0-9]*
ALL_TARGET= #
MAN1= par.1
-PLIST_FILES= bin/par
+PLIST_FILES= bin/par \
+ man/man1/par.1.gz
-NO_STAGE= yes
do-configure:
(cd ${WRKSRC}; ${CP} protoMakefile Makefile)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/par ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/par.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/par ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/par.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/textproc/par/files/patch-par.c b/textproc/par/files/patch-par.c
index 2bcf4868cec8..397e32c6cae5 100644
--- a/textproc/par/files/patch-par.c
+++ b/textproc/par/files/patch-par.c
@@ -1,5 +1,5 @@
---- par.c.orig Sun Mar 28 16:00:15 2004
-+++ par.c Sun Mar 28 16:04:00 2004
+--- ./par.c.orig 2001-04-02 05:25:57.000000000 +0100
++++ ./par.c 2014-02-10 21:14:29.000000000 +0000
@@ -403,7 +403,8 @@
}
continue;
diff --git a/textproc/par/files/patch-aa b/textproc/par/files/patch-protoMakefile
index e67c61a59d0e..1c11bccdb77f 100644
--- a/textproc/par/files/patch-aa
+++ b/textproc/par/files/patch-protoMakefile
@@ -1,11 +1,11 @@
---- protoMakefile.ORIG Sun Jan 21 05:46:02 1996
-+++ protoMakefile Mon Aug 17 18:56:27 1998
+--- ./protoMakefile.orig 2001-03-09 00:53:25.000000000 +0000
++++ ./protoMakefile 2014-02-10 21:14:29.000000000 +0000
@@ -47,7 +47,7 @@
# Example (for Solaris 2.x with SPARCompiler C):
# CC = cc -c -O -s -Xc -DDONTFREE
-
+
-CC = cc -c
+CC = cc -c ${CFLAGS}
-
+
# Define LINK1 and LINK2 so that the command
#
diff --git a/textproc/par/files/patch-reformat.c b/textproc/par/files/patch-reformat.c
new file mode 100644
index 000000000000..9b9d0f0d84ab
--- /dev/null
+++ b/textproc/par/files/patch-reformat.c
@@ -0,0 +1,11 @@
+--- ./reformat.c.orig 2014-02-10 21:14:43.000000000 +0000
++++ ./reformat.c 2014-02-10 21:17:35.000000000 +0000
+@@ -335,7 +335,7 @@
+ for (end = *line; *end; ++end);
+ if (end - *line < affix) {
+ sprintf(errmsg,
+- "Line %d shorter than <prefix> + <suffix> = %d + %d = %d\n",
++ "Line %zd shorter than <prefix> + <suffix> = %d + %d = %d\n",
+ line - inlines + 1, prefix, suffix, affix);
+ goto rfcleanup;
+ }