aboutsummaryrefslogtreecommitdiff
path: root/textproc/pdftohtml/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-18 08:15:26 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-18 08:15:26 +0000
commited9ca0dc5ad0294840258fcb7a12dc206c1a8e2e (patch)
tree5a3c2b869597066277da84ad15f3f7e5b11868f6 /textproc/pdftohtml/Makefile
parent0ca81fd4152cdef4c466c0f86d55756d0102a95d (diff)
Notes
Diffstat (limited to 'textproc/pdftohtml/Makefile')
-rw-r--r--textproc/pdftohtml/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index f4b7aeedf1e4..0d572376870a 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= pdftohtml
-PORTVERSION= 0.33a
+PORTVERSION= 0.34
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://ports.tolkien.dk/pdftohtml/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
@@ -19,6 +18,13 @@ MAINTAINER= erwin@lansing.dk
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
+pre-patch:
+.for file in goo/Makefile xpdf/Makefile
+ @${MV} ${WRKSRC}/${file} ${WRKSRC}/${file}.orig
+ @${SED} -e "s|-O2||; s|-g||" ${WRKSRC}/${file}.orig \
+ > ${WRKSRC}/${file}
+.endfor
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/pdftohtml ${PREFIX}/bin