aboutsummaryrefslogtreecommitdiff
path: root/textproc/pdftohtml
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-08 13:57:07 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-08 13:57:07 +0000
commit561325ed4b6a9cc7bcf4782fbe11361bc8d4cd69 (patch)
tree2e0d4587c0284ade84b233b2ba3d969740930bf1 /textproc/pdftohtml
parent652617f76f5aa7dc1762037fbb7276d00ef977ca (diff)
downloadports-561325ed4b6a9cc7bcf4782fbe11361bc8d4cd69.tar.gz
ports-561325ed4b6a9cc7bcf4782fbe11361bc8d4cd69.zip
Notes
Diffstat (limited to 'textproc/pdftohtml')
-rw-r--r--textproc/pdftohtml/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index d2b10cd7c469..93737c700a17 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -15,11 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= erwin@FreeBSD.org
COMMENT= A command-line tool for converting pdf-files into html
-RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/${GSPORT}
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_REINPLACE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
.for file in goo/Makefile xpdf/Makefile
${REINPLACE_CMD} -e "s|-O2||; s|-g||" ${WRKSRC}/${file}