aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-File_Fortune
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-29 14:07:54 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-29 14:07:54 +0000
commit64e2283a00cd3f82ddc5f14627f3c0a2ee87b4d9 (patch)
tree684534e8ca9f5bbcdfd71048ab06a8b7a47420bb /textproc/pear-File_Fortune
parentc67db2ccf5016c232ce88a951acd46e90da02152 (diff)
downloadports-64e2283a00cd3f82ddc5f14627f3c0a2ee87b4d9.tar.gz
ports-64e2283a00cd3f82ddc5f14627f3c0a2ee87b4d9.zip
Notes
Diffstat (limited to 'textproc/pear-File_Fortune')
-rw-r--r--textproc/pear-File_Fortune/Makefile34
-rw-r--r--textproc/pear-File_Fortune/distinfo3
-rw-r--r--textproc/pear-File_Fortune/files/patch-tests__File_FortuneTest.php11
-rw-r--r--textproc/pear-File_Fortune/pkg-descr9
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/pear-File_Fortune/Makefile b/textproc/pear-File_Fortune/Makefile
new file mode 100644
index 000000000000..144d59a47e80
--- /dev/null
+++ b/textproc/pear-File_Fortune/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-File_Fortune
+# Date created: 12 July 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Fortune
+PORTVERSION= 1.0.0
+CATEGORIES= textproc pear
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= An interface for reading from and writing to fortune files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= File
+FILES= Fortune.php Fortune/Exception.php
+_FILESDIR= File
+TESTS= AllTests.php File_FortuneTest.php orig/ftest orig/ftest.dat \
+ orig/ftest2 orig/ftest2.dat
+EXAMPLES= phpFortune
+DOCS= File_Fortune.cls
+_DOCSDIR= tutorials
+
+post-extract:
+ ${MV} ${WRKSRC}/File/Fortune.php ${WRKSRC}/File/Fortune ${WRKSRC}
+ ${MV} ${WRKSRC}/tests/_files/orig ${WRKSRC}/tests/orig
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-File_Fortune/distinfo b/textproc/pear-File_Fortune/distinfo
new file mode 100644
index 000000000000..09ec9b30280e
--- /dev/null
+++ b/textproc/pear-File_Fortune/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/File_Fortune-1.0.0.tgz) = 790f547447ade697d4227eca00107dec
+SHA256 (PEAR/File_Fortune-1.0.0.tgz) = 01867a3fa2c630a9821f30401f9cf4904eb9eae5cedd9e53b73c2cbc009753a0
+SIZE (PEAR/File_Fortune-1.0.0.tgz) = 14508
diff --git a/textproc/pear-File_Fortune/files/patch-tests__File_FortuneTest.php b/textproc/pear-File_Fortune/files/patch-tests__File_FortuneTest.php
new file mode 100644
index 000000000000..ca84694a386d
--- /dev/null
+++ b/textproc/pear-File_Fortune/files/patch-tests__File_FortuneTest.php
@@ -0,0 +1,11 @@
+--- ./tests/File_FortuneTest.php.orig 2007-07-12 11:31:59.515214662 +0800
++++ ./tests/File_FortuneTest.php 2007-07-12 11:32:15.386685251 +0800
+@@ -49,7 +49,7 @@
+ */
+ public function setUp()
+ {
+- $this->base = $base = dirname(__FILE__) . '/_files/';
++ $this->base = $base = dirname(__FILE__);
+ $origBase = $base . '/orig/';
+ foreach ($this->fortuneFiles as $file) {
+ copy($origBase . $file, $base . $file);
diff --git a/textproc/pear-File_Fortune/pkg-descr b/textproc/pear-File_Fortune/pkg-descr
new file mode 100644
index 000000000000..a7806b6d8a79
--- /dev/null
+++ b/textproc/pear-File_Fortune/pkg-descr
@@ -0,0 +1,9 @@
+File_Fortune provides a PHP interface to reading fortune files. With it, you may
+retrieve a single fortune, a random fortune, or all fortunes in the file.
+
+Additionally, it offers the ability to access fortune files as if they were a
+native array, including updating and deleting items. All write operations will
+produce a binary header file to allow compatability with the fortune and
+fortune-mod programs (as well as other fortune interfaces).
+
+WWW: http://pear.php.net/package/File_Fortune/