aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-XML_HTMLSax
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 19:09:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 19:09:35 +0000
commita6037d8db862661b7c8b50e8fa2785493cfc51a1 (patch)
tree375342e2f2b0bd98f1cad1acbe358a8eb70d7d1e /textproc/pear-XML_HTMLSax
parent19afc93c63f3cf670e3b6deae18a20689f1418ad (diff)
downloadports-a6037d8db862661b7c8b50e8fa2785493cfc51a1.tar.gz
ports-a6037d8db862661b7c8b50e8fa2785493cfc51a1.zip
Notes
Diffstat (limited to 'textproc/pear-XML_HTMLSax')
-rw-r--r--textproc/pear-XML_HTMLSax/Makefile29
-rw-r--r--textproc/pear-XML_HTMLSax/distinfo2
-rw-r--r--textproc/pear-XML_HTMLSax/pkg-descr12
3 files changed, 43 insertions, 0 deletions
diff --git a/textproc/pear-XML_HTMLSax/Makefile b/textproc/pear-XML_HTMLSax/Makefile
new file mode 100644
index 000000000000..9af9d06bf58e
--- /dev/null
+++ b/textproc/pear-XML_HTMLSax/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-XML_HTMLSax
+# Date created: 31 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_HTMLSax
+PORTVERSION= 2.1.2
+CATEGORIES= textproc devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR SAX parser for HTML and other badly formed XML documents
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= XML
+FILES= XML_HTMLSax.php HTMLSax/XML_HTMLSax_States.php \
+ HTMLSax/XML_HTMLSax_Decorators.php
+DOCS= Readme
+EXAMPLES= SimpleExample.php HTMLtoXHTML.php ExpatvsHtmlSax.php example.html
+TESTS= index.php unit_tests.php xml_htmlsax_test.php
+_EXAMPLESDIR= docs/examples
+_TESTSDIR= docs/tests
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-XML_HTMLSax/distinfo b/textproc/pear-XML_HTMLSax/distinfo
new file mode 100644
index 000000000000..af8b88368946
--- /dev/null
+++ b/textproc/pear-XML_HTMLSax/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/XML_HTMLSax-2.1.2.tgz) = f2cd9ea8ed1c59cc3046675d41c7cf98
+SIZE (PEAR/XML_HTMLSax-2.1.2.tgz) = 16099
diff --git a/textproc/pear-XML_HTMLSax/pkg-descr b/textproc/pear-XML_HTMLSax/pkg-descr
new file mode 100644
index 000000000000..149758c488f9
--- /dev/null
+++ b/textproc/pear-XML_HTMLSax/pkg-descr
@@ -0,0 +1,12 @@
+PEAR::XML_HTMLSax provides an API very similar to the native PHP XML
+extension (http://www.php.net/xml), allowing handlers using one to be easily
+adapted to the other.
+
+The key difference is HTMLSax will not break on badly formed XML, allowing it
+to be used for parsing HTML documents. Otherwise HTMLSax supports all the
+handlers available from Expat except namespace and external entity handlers.
+
+Provides methods for handling XML escapes as well as JSP/ASP opening and close
+tags.
+
+WWW: http://pear.php.net/package/XML_HTMLSax/