aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-YAML
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-07-11 09:54:52 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-07-11 09:54:52 +0000
commit5c4365e639e18aff4fcb7b8186c04a4e06bc92c4 (patch)
treef243ffba9c0b32fa937d4d41e96423bf4c3b5c76 /textproc/pear-YAML
parent0dcc808eb5d2bb362d3ce5b4c77cf751191bd225 (diff)
downloadports-5c4365e639e18aff4fcb7b8186c04a4e06bc92c4.tar.gz
ports-5c4365e639e18aff4fcb7b8186c04a4e06bc92c4.zip
Notes
Diffstat (limited to 'textproc/pear-YAML')
-rw-r--r--textproc/pear-YAML/Makefile28
-rw-r--r--textproc/pear-YAML/distinfo2
-rw-r--r--textproc/pear-YAML/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/textproc/pear-YAML/Makefile b/textproc/pear-YAML/Makefile
new file mode 100644
index 000000000000..f939307b4079
--- /dev/null
+++ b/textproc/pear-YAML/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-YAML
+# Date created: 11 July 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= YAML
+PORTVERSION= 1.0.6
+CATEGORIES= textproc www pear
+MASTER_SITES= http://pear.symfony-project.com/get/
+PKGNAMEPREFIX= pear-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= The Symfony YAML Component
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
+
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/.channels/pear.symfony-project.com.reg:${PORTSDIR}/devel/pear-channel-symfony
+
+PEAR_CHANNEL= symfony
+PEAR_AUTOINSTALL= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-YAML/distinfo b/textproc/pear-YAML/distinfo
new file mode 100644
index 000000000000..b676a1bc6f7a
--- /dev/null
+++ b/textproc/pear-YAML/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/YAML-1.0.6.tgz) = 8d2e7089e5727aef019185e2b9f7cbaabd5b6dbee31a2033d3145483d7d2694d
+SIZE (PEAR/YAML-1.0.6.tgz) = 10010
diff --git a/textproc/pear-YAML/pkg-descr b/textproc/pear-YAML/pkg-descr
new file mode 100644
index 000000000000..0378cd69e80e
--- /dev/null
+++ b/textproc/pear-YAML/pkg-descr
@@ -0,0 +1,4 @@
+Symfony YAML is a PHP library that parses YAML strings and converts them to
+PHP arrays. It can also converts PHP arrays to YAML strings.
+
+WWW: http://components.symfony-project.org/yaml/