aboutsummaryrefslogtreecommitdiff
path: root/textproc/pecl-ctemplate/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-05-07 13:39:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-05-07 13:39:49 +0000
commit31720e6c6da3cdb4530891d718a8238d604be36e (patch)
tree5e925be8ead7b0c3df82dc999fda61bfb5812e9f /textproc/pecl-ctemplate/Makefile
parent1d82e74887a109bfb28baf5193e3825c86963afd (diff)
downloadports-31720e6c6da3cdb4530891d718a8238d604be36e.tar.gz
ports-31720e6c6da3cdb4530891d718a8238d604be36e.zip
Notes
Diffstat (limited to 'textproc/pecl-ctemplate/Makefile')
-rw-r--r--textproc/pecl-ctemplate/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/pecl-ctemplate/Makefile b/textproc/pecl-ctemplate/Makefile
new file mode 100644
index 000000000000..4c926ec3116d
--- /dev/null
+++ b/textproc/pecl-ctemplate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pecl-cTemplate
+# Date created: 07 May 2006
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= cTemplate
+PORTVERSION= 0.1
+CATEGORIES= textproc pear
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= vanilla
+PKGNAMEPREFIX= pecl-
+DIST_SUBDIR= PECL
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A PECL extension for google ctemplate library
+
+LIB_DEPENDS= ctemplate.0:${PORTSDIR}/textproc/google-ctemplate
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${EXTRA_LIBS}"
+
+CONFIGURE_ARGS= --with-cTemplate=${LOCALBASE}
+
+.include <bsd.port.mk>