aboutsummaryrefslogtreecommitdiff
path: root/textproc/php55-xml
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
commit7fe96c109332ecdb411ceef911efd11085a88346 (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /textproc/php55-xml
parent47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (diff)
downloadports-7fe96c109332ecdb411ceef911efd11085a88346.tar.gz
ports-7fe96c109332ecdb411ceef911efd11085a88346.zip
Notes
Diffstat (limited to 'textproc/php55-xml')
-rw-r--r--textproc/php55-xml/Makefile10
-rw-r--r--textproc/php55-xml/files/patch-compat.c13
2 files changed, 23 insertions, 0 deletions
diff --git a/textproc/php55-xml/Makefile b/textproc/php55-xml/Makefile
new file mode 100644
index 000000000000..be8e8646b390
--- /dev/null
+++ b/textproc/php55-xml/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-xml/files/patch-compat.c b/textproc/php55-xml/files/patch-compat.c
new file mode 100644
index 000000000000..02125961b20c
--- /dev/null
+++ b/textproc/php55-xml/files/patch-compat.c
@@ -0,0 +1,13 @@
+--- compat.c.orig Tue Jul 20 10:55:02 2004
++++ compat.c Tue Jul 20 10:55:55 2004
+@@ -16,6 +16,10 @@
+ +----------------------------------------------------------------------+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #if defined(HAVE_LIBXML) && defined(HAVE_XML) && !defined(HAVE_LIBEXPAT)
+ #include "expat_compat.h"