aboutsummaryrefslogtreecommitdiff
path: root/textproc/po4a
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-29 22:48:08 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-29 22:48:08 +0000
commitcfdcaa6e5d30ef830436c2c58d3373df25b6c168 (patch)
tree13b140ec25ca606ad4c4dadaa7d9a2331cf40a43 /textproc/po4a
parent2662d29cb6cf62a31adde0cc29c665dac896b18d (diff)
downloadports-cfdcaa6e5d30ef830436c2c58d3373df25b6c168.tar.gz
ports-cfdcaa6e5d30ef830436c2c58d3373df25b6c168.zip
Notes
Diffstat (limited to 'textproc/po4a')
-rw-r--r--textproc/po4a/Makefile74
-rw-r--r--textproc/po4a/distinfo6
-rw-r--r--textproc/po4a/files/patch-Build.PL11
-rw-r--r--textproc/po4a/pkg-descr24
-rw-r--r--textproc/po4a/pkg-plist181
5 files changed, 140 insertions, 156 deletions
diff --git a/textproc/po4a/Makefile b/textproc/po4a/Makefile
index 92a72d7fb2b3..10a50389414e 100644
--- a/textproc/po4a/Makefile
+++ b/textproc/po4a/Makefile
@@ -6,48 +6,66 @@
#
PORTNAME= po4a
-PORTVERSION= 0.23
+PORTVERSION= 0.32
CATEGORIES= textproc perl5
-MASTER_SITES= ${MASTER_SITE_DEBIAN}
-MASTER_SITE_SUBDIR= pool/main/p/po4a
-DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+MASTER_SITES= http://alioth.debian.org/frs/download.php/2108/ GENTOO/distfiles
MAINTAINER= ports@FreeBSD.org
-COMMENT= Documentation gettext tools
+COMMENT= Brings gettext translation tools to all kinds of docs
-BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/Text/WrapI18N.pm:${PORTSDIR}/textproc/libtext-wrapi18n-perl \
- ${SITE_PERL}/SGMLS.pm:${PORTSDIR}/textproc/p5-SGMLSpm \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
+BUILD_DEPENDS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
+ libtext-wrapi18n-perl>=0.06:${PORTSDIR}/textproc/libtext-wrapi18n-perl \
+ p5-SGMLSpm>=1.03:${PORTSDIR}/textproc/p5-SGMLSpm \
+ p5-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext
USE_GETTEXT= yes
USE_PERL5= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PERL_MODBUILD= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= Locale::Po4a::TransTractor.3 \
+MANPREFIX= ${PREFIX}
+MAN3PREFIX= ${MANPREFIX}
+MANLANG= "" ca es fr it pl
+MAN3= \
+ Locale::Po4a::BibTeX.3 \
+ Locale::Po4a::Chooser.3 \
+ Locale::Po4a::Common.3 \
+ Locale::Po4a::Dia.3 \
+ Locale::Po4a::Docbook.3 \
+ Locale::Po4a::Guide.3 \
+ Locale::Po4a::Ini.3 \
+ Locale::Po4a::KernelHelp.3 \
Locale::Po4a::LaTeX.3 \
+ Locale::Po4a::Man.3 \
Locale::Po4a::Pod.3 \
Locale::Po4a::Po.3 \
Locale::Po4a::Sgml.3 \
+ Locale::Po4a::TeX.3 \
+ Locale::Po4a::Texinfo.3 \
Locale::Po4a::Text.3 \
- Locale::Po4a::Common.3 \
- Locale::Po4a::KernelHelp.3 \
- Locale::Po4a::Guide.3 \
- Locale::Po4a::Man.3 \
- Locale::Po4a::Xml.3 \
- Locale::Po4a::Dia.3 \
- Locale::Po4a::Docbook.3 \
- Locale::Po4a::Chooser.3 \
- Locale::Po4a::TeX.3
-
-MAN1= po4a-translate.1 \
+ Locale::Po4a::TransTractor.3 \
+ Locale::Po4a::Xhtml.3 \
+ Locale::Po4a::Xml.3
+MAN1= msguntypot.1 \
po4a.1 \
+ po4a-gettextize.1 \
po4a-normalize.1 \
- msguntypot.1 \
- po4a-updatepo.1 \
- po4a-gettextize.1
+ po4a-translate.1 \
+ po4a-updatepo.1
+MAN7= po4a.7
+
+PORT_VERBS= ${PORTNAME} Po4a msguntypot
+
+post-patch:
+ @${REINPLACE_CMD} -e '/install_path/s|/locale|/share&|;/my .options/s|-v|-k 0 &|;\
+ s|gzip|${TRUE}|g;s|3pm|3|g;s|1p|1|g' ${WRKSRC}/Build.PL
+
+post-install:
+ @${GZIP_CMD} ${MAN1PREFIX}/man/man1/po4aman-display-po.1
+
+enrich-plist:
+ @${ECHO_CMD} 'man/man1/po4aman-display-po.1${MANEXT}' >> ${PLIST}
+ @for i in ${MANLANG:M[a-z]*};do for n in 1 3 7;do\
+ ${ECHO_CMD} "@dirrmtry man/$$i/man$$n" >> ${PLIST};\
+ ${ECHO_CMD} "@dirrmtry man/$$i" >> ${PLIST};done;done
.include <bsd.port.mk>
diff --git a/textproc/po4a/distinfo b/textproc/po4a/distinfo
index c015cd481941..a728648c16cd 100644
--- a/textproc/po4a/distinfo
+++ b/textproc/po4a/distinfo
@@ -1,3 +1,3 @@
-MD5 (po4a_0.23.orig.tar.gz) = 858a312cff483d7ff3e0db7dfaf759d1
-SHA256 (po4a_0.23.orig.tar.gz) = 0e448e6609efefb37436d3507ab6265df46c94bcab0ea41fad1602ee5b4d6f04
-SIZE (po4a_0.23.orig.tar.gz) = 736399
+MD5 (po4a-0.32.tar.gz) = d026b224965b50afd9924b61d0df2a06
+SHA256 (po4a-0.32.tar.gz) = aab81329a73ea92b3a46c0a489017cc793b89b4c8beed84210253a35675c533e
+SIZE (po4a-0.32.tar.gz) = 882223
diff --git a/textproc/po4a/files/patch-Build.PL b/textproc/po4a/files/patch-Build.PL
deleted file mode 100644
index 536be51f1f95..000000000000
--- a/textproc/po4a/files/patch-Build.PL
+++ /dev/null
@@ -1,11 +0,0 @@
---- Build.PL.orig Mon Jan 23 13:59:39 2006
-+++ Build.PL Mon Jan 23 13:59:52 2006
-@@ -271,7 +271,7 @@
- 'po4a-translate', 'po4a-normalize', 'po4a', 'msguntypot'],
- add_to_cleanup => ['t/tmp','messages.mo', 'blib', 'html',
- 'po/pod/po4a-pod.pot~', 'po4a.log'],
-- install_path => {po => $base.'/locale', man => $base.'/man'},
-+ install_path => {po => $base.'/share/locale', man => $base.'/man'},
- dist_abstract => 'Tools for helping translation of documentation',
- dist_author => ['Martin Quinson (mquinson#debian.org)',
- 'Denis Barbier <barbier@linuxfr.org>']
diff --git a/textproc/po4a/pkg-descr b/textproc/po4a/pkg-descr
index cc5c2ad82ceb..b235748adefe 100644
--- a/textproc/po4a/pkg-descr
+++ b/textproc/po4a/pkg-descr
@@ -1,16 +1,16 @@
-tools for helping translation of documentation
-
The po4a (po for anything) project goal is to ease translations
(and more interestingly, the maintenance of translations) using
-gettext tools on areas where they were not expected like documentation.
-
-This package contains the main libraries of po4a, and the following sub-modules:
+gettext tools in areas where they were not expected, like
+documentation.
- - KernelHelp: Help messages of each kernel compilation option.
- - Man: Good old manual page format.
- - Pod: Perl documentation format.
- - Sgml: either debiandoc or docbook DTD.
- - Dia: uncompressed Dia diagrams.
- - LaTeX: generic TeX or LaTeX format
+po4a supports currently the following formats:
+* manpages
+* pod
+* xml (generic, docbook, xhtml, dia, or guide)
+* sgml
+* TeX (generic, LaTeX, or Texinfo)
+* text (simple text files with some formatting)
+* ini
+* KernelHelp
-WWW: http://packages.debian.org/unstable/text/po4a
+WWW: http://po4a.alioth.debian.org/
diff --git a/textproc/po4a/pkg-plist b/textproc/po4a/pkg-plist
index 2b536530d12c..e6f0cd03603a 100644
--- a/textproc/po4a/pkg-plist
+++ b/textproc/po4a/pkg-plist
@@ -1,119 +1,96 @@
-bin/po4a-normalize
-bin/po4a-gettextize
bin/msguntypot
-bin/po4a-updatepo
bin/po4a
+bin/po4a-gettextize
+bin/po4a-normalize
bin/po4a-translate
-man/ca/man1/po4a-normalize.1p.gz
-man/ca/man1/po4a-gettextize.1p.gz
-man/ca/man1/po4a-updatepo.1p.gz
-man/ca/man1/po4a-translate.1p.gz
-man/ca/man3/Locale::Po4a::Dia.3pm.gz
-man/ca/man3/Locale::Po4a::Po.3pm.gz
-man/ca/man3/Locale::Po4a::LaTeX.3pm.gz
-man/ca/man3/Locale::Po4a::Pod.3pm.gz
-man/ca/man3/Locale::Po4a::Xml.3pm.gz
-man/ca/man3/Locale::Po4a::TransTractor.3pm.gz
-man/ca/man3/Locale::Po4a::Guide.3pm.gz
-man/ca/man3/Locale::Po4a::KernelHelp.3pm.gz
-man/ca/man3/Locale::Po4a::Chooser.3pm.gz
-man/ca/man3/Locale::Po4a::Docbook.3pm.gz
-man/es/man1/po4a-normalize.1p.gz
-man/es/man1/po4a-gettextize.1p.gz
-man/es/man1/po4a-updatepo.1p.gz
-man/es/man1/po4a-translate.1p.gz
-man/es/man3/Locale::Po4a::Dia.3pm.gz
-man/es/man3/Locale::Po4a::Po.3pm.gz
-man/es/man3/Locale::Po4a::LaTeX.3pm.gz
-man/es/man3/Locale::Po4a::Pod.3pm.gz
-man/es/man3/Locale::Po4a::Xml.3pm.gz
-man/es/man3/Locale::Po4a::TransTractor.3pm.gz
-man/es/man3/Locale::Po4a::Guide.3pm.gz
-man/es/man3/Locale::Po4a::KernelHelp.3pm.gz
-man/es/man3/Locale::Po4a::Chooser.3pm.gz
-man/es/man3/Locale::Po4a::Docbook.3pm.gz
-man/fr/man1/po4a-normalize.1p.gz
-man/fr/man1/msguntypot.1p.gz
-man/fr/man1/po4a-gettextize.1p.gz
-man/fr/man1/po4a.1p.gz
-man/fr/man1/po4a-updatepo.1p.gz
-man/fr/man1/po4a-translate.1p.gz
-man/fr/man3/Locale::Po4a::Dia.3pm.gz
-man/fr/man3/Locale::Po4a::Po.3pm.gz
-man/fr/man3/Locale::Po4a::Man.3pm.gz
-man/fr/man3/Locale::Po4a::LaTeX.3pm.gz
-man/fr/man3/Locale::Po4a::Pod.3pm.gz
-man/fr/man3/Locale::Po4a::TeX.3pm.gz
-man/fr/man3/Locale::Po4a::TransTractor.3pm.gz
-man/fr/man3/Locale::Po4a::Xml.3pm.gz
-man/fr/man3/Locale::Po4a::Guide.3pm.gz
-man/fr/man3/Locale::Po4a::Docbook.3pm.gz
-man/fr/man3/Locale::Po4a::KernelHelp.3pm.gz
-man/fr/man3/Locale::Po4a::Chooser.3pm.gz
-man/fr/man3/Locale::Po4a::Sgml.3pm.gz
-man/fr/man3/Locale::Po4a::Text.3pm.gz
-man/fr/man3/Locale::Po4a::Common.3pm.gz
-man/it/man1/po4a-normalize.1p.gz
-man/it/man1/po4a-gettextize.1p.gz
-man/it/man1/po4a-updatepo.1p.gz
-man/it/man1/po4a-translate.1p.gz
-man/it/man3/Locale::Po4a::Dia.3pm.gz
-man/it/man3/Locale::Po4a::Pod.3pm.gz
-man/it/man3/Locale::Po4a::Guide.3pm.gz
-man/it/man3/Locale::Po4a::KernelHelp.3pm.gz
-man/it/man3/Locale::Po4a::Chooser.3pm.gz
-man/it/man3/Locale::Po4a::Docbook.3pm.gz
-man/pl/man1/po4a-normalize.1p.gz
-man/pl/man1/msguntypot.1p.gz
-man/pl/man1/po4a-gettextize.1p.gz
-man/pl/man1/po4a.1p.gz
-man/pl/man1/po4a-updatepo.1p.gz
-man/pl/man1/po4a-translate.1p.gz
-man/pl/man3/Locale::Po4a::Dia.3pm.gz
-man/pl/man3/Locale::Po4a::Po.3pm.gz
-man/pl/man3/Locale::Po4a::Man.3pm.gz
-man/pl/man3/Locale::Po4a::LaTeX.3pm.gz
-man/pl/man3/Locale::Po4a::Pod.3pm.gz
-man/pl/man3/Locale::Po4a::TeX.3pm.gz
-man/pl/man3/Locale::Po4a::TransTractor.3pm.gz
-man/pl/man3/Locale::Po4a::Xml.3pm.gz
-man/pl/man3/Locale::Po4a::Guide.3pm.gz
-man/pl/man3/Locale::Po4a::Docbook.3pm.gz
-man/pl/man3/Locale::Po4a::KernelHelp.3pm.gz
-man/pl/man3/Locale::Po4a::Chooser.3pm.gz
-man/pl/man3/Locale::Po4a::Sgml.3pm.gz
-man/pl/man3/Locale::Po4a::Text.3pm.gz
-man/pl/man3/Locale::Po4a::Common.3pm.gz
-man/man7/po4a.7.gz
-man/es/man7/po4a.7.gz
-man/fr/man7/po4a.7.gz
-man/pl/man7/po4a.7.gz
-man/ca/man7/po4a.7.gz
-%%SITE_PERL%%/Locale/Po4a/Pod.pm
-%%SITE_PERL%%/Locale/Po4a/Dia.pm
-%%SITE_PERL%%/Locale/Po4a/LaTeX.pm
+bin/po4a-updatepo
+bin/po4aman-display-po
+%%SITE_PERL%%/Locale/Po4a/BibTeX.pm
+%%SITE_PERL%%/Locale/Po4a/Chooser.pm
%%SITE_PERL%%/Locale/Po4a/Common.pm
-%%SITE_PERL%%/Locale/Po4a/Xml.pm
+%%SITE_PERL%%/Locale/Po4a/Dia.pm
%%SITE_PERL%%/Locale/Po4a/Docbook.pm
-%%SITE_PERL%%/Locale/Po4a/TeX.pm
-%%SITE_PERL%%/Locale/Po4a/KernelHelp.pm
-%%SITE_PERL%%/Locale/Po4a/Sgml.pm
%%SITE_PERL%%/Locale/Po4a/Guide.pm
-%%SITE_PERL%%/Locale/Po4a/Po.pm
+%%SITE_PERL%%/Locale/Po4a/Ini.pm
+%%SITE_PERL%%/Locale/Po4a/KernelHelp.pm
+%%SITE_PERL%%/Locale/Po4a/LaTeX.pm
%%SITE_PERL%%/Locale/Po4a/Man.pm
-%%SITE_PERL%%/Locale/Po4a/TransTractor.pm
-%%SITE_PERL%%/Locale/Po4a/Chooser.pm
+%%SITE_PERL%%/Locale/Po4a/Po.pm
+%%SITE_PERL%%/Locale/Po4a/Pod.pm
+%%SITE_PERL%%/Locale/Po4a/Sgml.pm
+%%SITE_PERL%%/Locale/Po4a/TeX.pm
+%%SITE_PERL%%/Locale/Po4a/Texinfo.pm
%%SITE_PERL%%/Locale/Po4a/Text.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/po4a/.packlist
+%%SITE_PERL%%/Locale/Po4a/TransTractor.pm
+%%SITE_PERL%%/Locale/Po4a/Xhtml.pm
+%%SITE_PERL%%/Locale/Po4a/Xml.pm
share/locale/af/LC_MESSAGES/po4a.mo
+share/locale/ar/LC_MESSAGES/po4a.mo
+share/locale/bn/LC_MESSAGES/po4a.mo
share/locale/ca/LC_MESSAGES/po4a.mo
-share/locale/de/LC_MESSAGES/po4a.mo
share/locale/cs/LC_MESSAGES/po4a.mo
+share/locale/de/LC_MESSAGES/po4a.mo
+share/locale/eo/LC_MESSAGES/po4a.mo
share/locale/es/LC_MESSAGES/po4a.mo
+share/locale/et/LC_MESSAGES/po4a.mo
+share/locale/eu/LC_MESSAGES/po4a.mo
share/locale/fr/LC_MESSAGES/po4a.mo
+share/locale/he/LC_MESSAGES/po4a.mo
+share/locale/hr/LC_MESSAGES/po4a.mo
+share/locale/id/LC_MESSAGES/po4a.mo
share/locale/it/LC_MESSAGES/po4a.mo
+share/locale/kn/LC_MESSAGES/po4a.mo
+share/locale/ko/LC_MESSAGES/po4a.mo
+share/locale/ku/LC_MESSAGES/po4a.mo
+share/locale/nb/LC_MESSAGES/po4a.mo
+share/locale/nl/LC_MESSAGES/po4a.mo
+share/locale/oc/LC_MESSAGES/po4a.mo
share/locale/pl/LC_MESSAGES/po4a.mo
+share/locale/pt/LC_MESSAGES/po4a.mo
+share/locale/pt_BR/LC_MESSAGES/po4a.mo
share/locale/ru/LC_MESSAGES/po4a.mo
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/po4a
-@dirrm %%SITE_PERL%%/Locale/Po4a
+share/locale/sl/LC_MESSAGES/po4a.mo
+share/locale/sv/LC_MESSAGES/po4a.mo
+share/locale/uk/LC_MESSAGES/po4a.mo
+share/locale/uz/LC_MESSAGES/po4a.mo
+share/locale/zh_CN/LC_MESSAGES/po4a.mo
+share/locale/zh_HK/LC_MESSAGES/po4a.mo
+@dirrmtry %%SITE_PERL%%/Locale/Po4a
@dirrmtry %%SITE_PERL%%/Locale
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+man/man1/po4aman-display-po.1.gz
+@dirrmtry man/ca/man1
+@dirrmtry man/ca
+@dirrmtry man/ca/man3
+@dirrmtry man/ca
+@dirrmtry man/ca/man7
+@dirrmtry man/ca
+@dirrmtry man/es/man1
+@dirrmtry man/es
+@dirrmtry man/es/man3
+@dirrmtry man/es
+@dirrmtry man/es/man7
+@dirrmtry man/es
+@dirrmtry man/fr/man1
+@dirrmtry man/fr
+@dirrmtry man/fr/man3
+@dirrmtry man/fr
+@dirrmtry man/fr/man7
+@dirrmtry man/fr
+@dirrmtry man/it/man1
+@dirrmtry man/it
+@dirrmtry man/it/man3
+@dirrmtry man/it
+@dirrmtry man/it/man7
+@dirrmtry man/it
+@dirrmtry man/pl/man1
+@dirrmtry man/pl
+@dirrmtry man/pl/man3
+@dirrmtry man/pl
+@dirrmtry man/pl/man7
+@dirrmtry man/pl