aboutsummaryrefslogtreecommitdiff
path: root/textproc/pootle/Makefile
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-09-15 19:28:20 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-09-15 19:28:20 +0000
commited40efd2a94e2deec526a70b7b985ee322641081 (patch)
treebb29df03b45e6c9dd0e26338a394ee6f5c4ef90b /textproc/pootle/Makefile
parent394fc06249bb00e5510cad17cd51c4018aaea20e (diff)
downloadports-ed40efd2a94e2deec526a70b7b985ee322641081.tar.gz
ports-ed40efd2a94e2deec526a70b7b985ee322641081.zip
Notes
Diffstat (limited to 'textproc/pootle/Makefile')
-rw-r--r--textproc/pootle/Makefile29
1 files changed, 26 insertions, 3 deletions
diff --git a/textproc/pootle/Makefile b/textproc/pootle/Makefile
index a6f068ef76f7..7baabfbcd909 100644
--- a/textproc/pootle/Makefile
+++ b/textproc/pootle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pootle
-PORTVERSION= 2.0.5
+PORTVERSION= 2.1.1
CATEGORIES= textproc
MASTER_SITES= SF/translate/Pootle/${PORTVERSION}/
DISTNAME= Pootle-${PORTVERSION}
@@ -14,8 +14,9 @@ DISTNAME= Pootle-${PORTVERSION}
MAINTAINER= catone@cpan.org
COMMENT= Pootle is a user-friendly web portal for simple translation process
-BUILD_DEPENDS= py*-django>=1.1:${PORTSDIR}/www/py-django \
- translate-toolkit>=1.6:${PORTSDIR}/textproc/translate-toolkit
+BUILD_DEPENDS= py*-django>=1.2:${PORTSDIR}/www/py-django \
+ translate-toolkit>=1.8:${PORTSDIR}/textproc/translate-toolkit \
+ ${PYTHON_SITELIBDIR}/South-0.7.1-py2.6.egg:${PORTSDIR}/databases/py-south
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -51,8 +52,30 @@ PKGINSTALL= ${WRKDIR}/pkg-install
PORTDOCS= ChangeLog COPYING INSTALL README wsgi.py
+OPTIONS= MYSQL "MYSQL support" on \
+ SUBVERSION "SVN support" on \
+ LUCENE "py-lucene for faster searching" on \
+ MEMCACHED "Enable memcached support" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+.endif
+
+.if defined(WITH_SUBVERSION)
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+.endif
+
+.if defined(WITH_LUCENE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/lucene/_lucene.so:${PORTSDIR}/textproc/py-lucene
+.endif
+
+.if defined(WITH_MEMCACHED)
+LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/python_memcached-1.45-py2.6.egg:${PORTSDIR}/databases/py-memcached
+.endif
+
post-patch:
@${MV} ${WRKSRC}/localsettings.py ${WRKSRC}/localsettings.py.sample
@${REINPLACE_CMD} -e "s|^CONFIG_DIR.*=.*|CONFIG_DIR = \'${PREFIX}/etc/pootle\'|g" \