aboutsummaryrefslogtreecommitdiff
path: root/textproc/pootle/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /textproc/pootle/Makefile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'textproc/pootle/Makefile')
-rw-r--r--textproc/pootle/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/textproc/pootle/Makefile b/textproc/pootle/Makefile
index 3107994f870c..4bac5a0af244 100644
--- a/textproc/pootle/Makefile
+++ b/textproc/pootle/Makefile
@@ -15,21 +15,21 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= translate-toolkit>=1.11.0:textproc/translate-toolkit \
- ${PYTHON_PKGNAMEPREFIX}south>=0.7.6:databases/py-south\
- ${PYTHON_PKGNAMEPREFIX}cssmin>=0.1.4:www/py-cssmin \
- ${PYTHON_PKGNAMEPREFIX}lxml>=2.1.4:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}django-taggit>0.10:www/py-django-taggit \
- ${PYTHON_PKGNAMEPREFIX}django-assets>=0.8:www/py-django-assets \
- ${PYTHON_PKGNAMEPREFIX}south>=0.7.6:databases/py-south \
- ${PYTHON_PKGNAMEPREFIX}django-voting>=0.1:www/py-django-voting \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson \
- ${PYTHON_PKGNAMEPREFIX}argparse>=0:devel/py-argparse \
- ${PYTHON_PKGNAMEPREFIX}diff-match-patch>=0:textproc/py-diff-match-patch
+ ${PYTHON_PKGNAMEPREFIX}south>=0.7.6:databases/py-south@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cssmin>=0.1.4:www/py-cssmin@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.1.4:devel/py-lxml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-taggit>0.10:www/py-django-taggit@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-assets>=0.8:www/py-django-assets@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}south>=0.7.6:databases/py-south@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-voting>=0.1:www/py-django-voting@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}argparse>=0:devel/py-argparse@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}diff-match-patch>=0:textproc/py-diff-match-patch@${FLAVOR}
# actually diff-match-patch is a dependency of translate-toolkit,
# but only this port uses it.
NO_ARCH= yes
-USES= gettext python tar:bzip2 shebangfix
+USES= gettext python:2.7 tar:bzip2 shebangfix
USE_PYTHON= autoplist distutils
SHEBANG_FILES= pootle/assets/admin/js/compress.py
@@ -49,14 +49,14 @@ OPTIONS_DEFAULT=MEMCACHED MYSQL
MEMCACHED_DESC= Use memcached to improve performance
-LDAP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap2>0:devel/py-ldap2
+LDAP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap2>0:devel/py-ldap2@${FLAVOR}
MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
-MEMCACHED_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-memcached>=1.45:databases/py-python-memcached
+MEMCACHED_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-memcached>=1.45:databases/py-python-memcached@${FLAVOR}
-MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>0:databases/py-MySQLdb
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>0:databases/py-MySQLdb@${FLAVOR}
-PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${FLAVOR}
SUBVERSION_RUN_DEPENDS= svn:devel/subversion