aboutsummaryrefslogtreecommitdiff
path: root/textproc/ppower4/Makefile
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2006-08-28 18:40:20 +0000
committerStefan Walter <stefan@FreeBSD.org>2006-08-28 18:40:20 +0000
commit665d68243ad1a325e75e5889b691b50a0ac3b9fe (patch)
tree4b37ca3582b8c85490eaafa3d16b3934cc6114cd /textproc/ppower4/Makefile
parentdd949d9591baf904781bfe0bbf447891350cc5ae (diff)
Notes
Diffstat (limited to 'textproc/ppower4/Makefile')
-rw-r--r--textproc/ppower4/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/textproc/ppower4/Makefile b/textproc/ppower4/Makefile
index 50d04ae8922a..90cead0ebe63 100644
--- a/textproc/ppower4/Makefile
+++ b/textproc/ppower4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ppower4
PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc java
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/${PORTNAME}
@@ -18,15 +18,16 @@ EXTRACT_ONLY= pp4sty.zip leveldemo.zip
MAINTAINER= stefan@FreeBSD.org
COMMENT= Post processor for PDF presentations made with (La)TeX
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+ java:${PORTSDIR}/java/javavmwrapper
USE_ZIP= yes
-USE_JAVA= 1.3+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
NO_BUILD= yes
-NO_BUILD_DEPENDS_JAVA= yes
NO_WRKSUBDIR= yes
-JAR_DIR= ${JAVAJARDIR}/${PORTNAME}
+JAR_DIR= ${JAVASHAREDIR}/${PORTNAME}
STY_DIR= ${PREFIX}/share/texmf/tex/latex/${PORTNAME}
STY_FILES= ${WRKDIR}/pause.sty ${WRKDIR}/background.sty \
${WRKDIR}/pp4link.sty ${WRKDIR}/mpmulti.sty
@@ -37,11 +38,8 @@ EXAMPLE_FILES+= ${WRKDIR}/example.${i}
PLIST_SUB= STY_DIR="${STY_DIR:S,^${PREFIX}/,,}" \
JAR_DIR="${JAR_DIR:S,^${PREFIX}/,,}"
-post-patch:
-# prepare wrapper script
- @${SED} -e "s,%%JAVAVM%%,${LOCALBASE}/bin/javavm,; \
- s,%%JARFILE%%,${JAR_DIR}/pp4p.jar," \
- ${FILESDIR}/ppower4 > ${WRKDIR}/ppower4
+SUB_FILES= ppower4.sh
+SUB_LIST= JARFILE=${JAR_DIR}/pp4p.jar
do-install:
# install docs?
@@ -59,7 +57,7 @@ do-install:
@${MKDIR} ${JAR_DIR}
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/pp4p.jar ${JAR_DIR}
# install wrapper script
- @${INSTALL_SCRIPT} ${WRKDIR}/ppower4 ${PREFIX}/bin/ppower4
+ @${INSTALL_SCRIPT} ${WRKDIR}/ppower4.sh ${PREFIX}/bin/ppower4
post-install:
${SETENV} LOCALBASE=${LOCALBASE} PKG_PREFIX=${PREFIX} \