aboutsummaryrefslogtreecommitdiff
path: root/textproc/prosper
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-11-07 04:30:33 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-11-07 04:30:33 +0000
commit38caf2b2974b7a0aa310502b71687904e23f1392 (patch)
tree277df05624b419adf7f4d5a9eb58a1b7da16c1ac /textproc/prosper
parentdbd50d410371b2187d67b5cdffe6f8bafb965cd2 (diff)
downloadports-38caf2b2974b7a0aa310502b71687904e23f1392.tar.gz
ports-38caf2b2974b7a0aa310502b71687904e23f1392.zip
Notes
Diffstat (limited to 'textproc/prosper')
-rw-r--r--textproc/prosper/Makefile12
-rw-r--r--textproc/prosper/pkg-plist22
2 files changed, 26 insertions, 8 deletions
diff --git a/textproc/prosper/Makefile b/textproc/prosper/Makefile
index 1fe37b2bc09c..18f6695f7771 100644
--- a/textproc/prosper/Makefile
+++ b/textproc/prosper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= prosper
PORTVERSION= 1.00.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,6 +21,7 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
NO_BUILD= yes
USE_GHOSTSCRIPT_RUN= yes
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -28,7 +29,8 @@ TEXMFDIR?= share/texmf
LPROSPERDIR= ${TEXMFDIR}/tex/latex/prosper
PROSPERDIR= ${PREFIX}/${LPROSPERDIR}
-PLIST_SUB= PROSPERDIR=${LPROSPERDIR}
+PLIST_SUB= PROSPERDIR=${LPROSPERDIR} \
+ MKTEXLSR=${MKTEXLSR}
DOCS= AUTHORS ChangeLog FAQ INSTALL NEWS README TODO \
TROUBLESHOOTINGS doc/compilation.eps doc/compilation.fig \
@@ -61,8 +63,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/contrib/*.ps ${PROSPERDIR}/contrib
${INSTALL_DATA} ${WRKSRC}/contrib/*.tex ${PROSPERDIR}/contrib
${INSTALL_DATA} ${WRKSRC}/contrib/img/*.ps ${PROSPERDIR}/contrib/img
+ ${INSTALL_DATA} ${WRKSRC}/contrib/img/*.eps ${PROSPERDIR}/contrib/img
+ ${INSTALL_DATA} ${WRKSRC}/contrib/img/*.gif ${PROSPERDIR}/contrib/img
${INSTALL_DATA} ${WRKSRC}/designer/prosper* ${PROSPERDIR}/designer
- mktexlsr
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -76,4 +79,7 @@ do-install:
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
+post-install:
+ ${MKTEXLSR}
+
.include <bsd.port.mk>
diff --git a/textproc/prosper/pkg-plist b/textproc/prosper/pkg-plist
index f43ebb30a169..f801f928159c 100644
--- a/textproc/prosper/pkg-plist
+++ b/textproc/prosper/pkg-plist
@@ -38,17 +38,29 @@
%%PORTDOCS%%%%EXAMPLESDIR%%/ExampleTroisPoints.tex
%%PROSPERDIR%%/contrib/img/angleHG.ps
%%PROSPERDIR%%/contrib/img/barre-rico.ps
-%%PROSPERDIR%%/contrib/img/rico_bullet1.ps
-%%PROSPERDIR%%/contrib/img/rico_bullet2.ps
-%%PROSPERDIR%%/contrib/img/rico_bullet3.ps
%%PROSPERDIR%%/contrib/img/blue-inverted-arrow.ps
+%%PROSPERDIR%%/contrib/img/boule-base.eps
+%%PROSPERDIR%%/contrib/img/boulebleue-fondblanc.eps
+%%PROSPERDIR%%/contrib/img/boulerouge-fondblanc.eps
+%%PROSPERDIR%%/contrib/img/bouleverte-fondblanc.eps
+%%PROSPERDIR%%/contrib/img/degrade-base.eps
+%%PROSPERDIR%%/contrib/img/degrade-blanc-bleu.eps
+%%PROSPERDIR%%/contrib/img/green-bullet-on-blue-wc.gif
%%PROSPERDIR%%/contrib/img/green-bullet-on-blue-wc.ps
+%%PROSPERDIR%%/contrib/img/green-bullet-on-white.gif
%%PROSPERDIR%%/contrib/img/green-bullet-on-white.ps
%%PROSPERDIR%%/contrib/img/green-inverted-arrow.ps
+%%PROSPERDIR%%/contrib/img/red-bullet-on-blue-wc.gif
%%PROSPERDIR%%/contrib/img/red-bullet-on-blue-wc.ps
+%%PROSPERDIR%%/contrib/img/red-bullet-on-white.gif
%%PROSPERDIR%%/contrib/img/red-bullet-on-white.ps
%%PROSPERDIR%%/contrib/img/red-inverted-arrow.ps
+%%PROSPERDIR%%/contrib/img/rico_bullet1.ps
+%%PROSPERDIR%%/contrib/img/rico_bullet2.ps
+%%PROSPERDIR%%/contrib/img/rico_bullet3.ps
+%%PROSPERDIR%%/contrib/img/yellow-bullet-on-blue-wc.gif
%%PROSPERDIR%%/contrib/img/yellow-bullet-on-blue-wc.ps
+%%PROSPERDIR%%/contrib/img/yellow-bullet-on-white.gif
%%PROSPERDIR%%/contrib/img/yellow-bullet-on-white.ps
%%PROSPERDIR%%/contrib/PPRalcatel.sty
%%PROSPERDIR%%/contrib/PPRblends.sty
@@ -106,5 +118,5 @@
@dirrm %%PROSPERDIR%%/designer
@dirrm %%PROSPERDIR%%/img
@dirrm %%PROSPERDIR%%
-@exec %D/bin/mktexlsr
-@unexec %D/bin/mktexlsr
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%