aboutsummaryrefslogtreecommitdiff
path: root/textproc/pure-csv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:47:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:47:00 +0000
commitb4c2350afcd08f033910a7662ca0c87c3d79dcc7 (patch)
treed808d2a750260248b2dcebcbdcd62b9f8783bea8 /textproc/pure-csv
parentae90397d31045e2d94ad13561abd3ba3337a336c (diff)
downloadports-b4c2350afcd08f033910a7662ca0c87c3d79dcc7.tar.gz
ports-b4c2350afcd08f033910a7662ca0c87c3d79dcc7.zip
Notes
Diffstat (limited to 'textproc/pure-csv')
-rw-r--r--textproc/pure-csv/Makefile29
-rw-r--r--textproc/pure-csv/distinfo2
-rw-r--r--textproc/pure-csv/pkg-descr4
3 files changed, 35 insertions, 0 deletions
diff --git a/textproc/pure-csv/Makefile b/textproc/pure-csv/Makefile
new file mode 100644
index 000000000000..f537621ede4e
--- /dev/null
+++ b/textproc/pure-csv/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pure-csv
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-csv
+PORTVERSION= 1.4
+CATEGORIES= textproc
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A CSV reading and writing module for the Pure langauge
+
+LIB_DEPENDS+= pure:${PORTSDIR}/lang/pure
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= lib/pure/csv.pure \
+ lib/pure/csv.so
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib CFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/textproc/pure-csv/distinfo b/textproc/pure-csv/distinfo
new file mode 100644
index 000000000000..34ce5f656e93
--- /dev/null
+++ b/textproc/pure-csv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-csv-1.4.tar.gz) = 9b61f9c73a23a710ab9c77e039480d5fbf0a55e11c1a2dbeb9846411a1c68880
+SIZE (pure-csv-1.4.tar.gz) = 26549
diff --git a/textproc/pure-csv/pkg-descr b/textproc/pure-csv/pkg-descr
new file mode 100644
index 000000000000..7d76ed23a789
--- /dev/null
+++ b/textproc/pure-csv/pkg-descr
@@ -0,0 +1,4 @@
+pure-csv is a module for reading and writing Comma Separated Value (CSV)
+files from within Pure.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-csv.html