aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-acora
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-08-23 08:16:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-08-23 08:16:57 +0000
commit618563f0d3b972b9b9075da7e928ca8451a49e77 (patch)
tree7b3e769200675bce4c38e4dc571bc7bfafb79cc2 /textproc/py-acora
parentfd783fb630ca5b3625609ba9a58fb0a863b2223b (diff)
New port: textproc/py-acora
Acora is 'fgrep' for Python, a fast multi-keyword text search engine. Based on a set of keywords, it generates a search automaton (DFA) and runs it over string input, either unicode or bytes. It is based on the Aho-Corasick algorithm and an NFA-to-DFA powerset construction. Acora comes with both a pure Python implementation and a fast binary module written in Cython. However, note that the current construction algorithm is not suitable for really large sets of keywords (i.e. more than a couple of thousand). WWW: https://github.com/scoder/acora/
Notes
Notes: svn path=/head/; revision=365714
Diffstat (limited to 'textproc/py-acora')
-rw-r--r--textproc/py-acora/Makefile19
-rw-r--r--textproc/py-acora/distinfo2
-rw-r--r--textproc/py-acora/pkg-descr9
3 files changed, 30 insertions, 0 deletions
diff --git a/textproc/py-acora/Makefile b/textproc/py-acora/Makefile
new file mode 100644
index 000000000000..1aa8127a10ec
--- /dev/null
+++ b/textproc/py-acora/Makefile
@@ -0,0 +1,19 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= acora
+PORTVERSION= 1.8
+CATEGORIES= textproc devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Fast multi-keyword search engine for text strings
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-acora/distinfo b/textproc/py-acora/distinfo
new file mode 100644
index 000000000000..559d95639125
--- /dev/null
+++ b/textproc/py-acora/distinfo
@@ -0,0 +1,2 @@
+SHA256 (acora-1.8.tar.gz) = cfabfbccc31762ae54d05119331051c99837e77e1204c38b9d142f0375c6725b
+SIZE (acora-1.8.tar.gz) = 123811
diff --git a/textproc/py-acora/pkg-descr b/textproc/py-acora/pkg-descr
new file mode 100644
index 000000000000..886bfef9b3a3
--- /dev/null
+++ b/textproc/py-acora/pkg-descr
@@ -0,0 +1,9 @@
+Acora is 'fgrep' for Python, a fast multi-keyword text search engine.
+Based on a set of keywords, it generates a search automaton (DFA) and runs it
+over string input, either unicode or bytes. It is based on the Aho-Corasick
+algorithm and an NFA-to-DFA powerset construction. Acora comes with both a pure
+Python implementation and a fast binary module written in Cython. However, note
+that the current construction algorithm is not suitable for really large sets of
+keywords (i.e. more than a couple of thousand).
+
+WWW: https://github.com/scoder/acora/