aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-atoml
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:44:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:48:07 +0000
commitd08cccaa487fc24db7a691ef29ae48a01dbef2d2 (patch)
treef619a742ce533da0e920d6d72b797338417978c6 /textproc/py-atoml
parenta2663b5d194c51e28906bfbc7f741312501cdc68 (diff)
downloadports-d08cccaa487fc24db7a691ef29ae48a01dbef2d2.tar.gz
ports-d08cccaa487fc24db7a691ef29ae48a01dbef2d2.zip
Diffstat (limited to 'textproc/py-atoml')
-rw-r--r--textproc/py-atoml/Makefile23
-rw-r--r--textproc/py-atoml/distinfo3
-rw-r--r--textproc/py-atoml/files/setup.py39
-rw-r--r--textproc/py-atoml/pkg-descr9
4 files changed, 74 insertions, 0 deletions
diff --git a/textproc/py-atoml/Makefile b/textproc/py-atoml/Makefile
new file mode 100644
index 000000000000..4d5bd973a4ff
--- /dev/null
+++ b/textproc/py-atoml/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= atoml
+PORTVERSION= 1.0.3
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Yet another style preserving TOML library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
+
+.include <bsd.port.mk>
diff --git a/textproc/py-atoml/distinfo b/textproc/py-atoml/distinfo
new file mode 100644
index 000000000000..a971eb637498
--- /dev/null
+++ b/textproc/py-atoml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632760428
+SHA256 (atoml-1.0.3.tar.gz) = 5dd70efcafde94a6aa5db2e8c6af5d832bf95b38f47d3283ee3779e920218e94
+SIZE (atoml-1.0.3.tar.gz) = 134947
diff --git a/textproc/py-atoml/files/setup.py b/textproc/py-atoml/files/setup.py
new file mode 100644
index 000000000000..95c58e86aea1
--- /dev/null
+++ b/textproc/py-atoml/files/setup.py
@@ -0,0 +1,39 @@
+
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+import codecs
+
+with codecs.open('README.md', encoding="utf-8") as fp:
+ long_description = fp.read()
+
+setup_kwargs = {
+ 'name': 'atoml',
+ 'version': '1.0.3',
+ 'description': 'Yet another style preserving TOML library',
+ 'long_description': long_description,
+ 'license': 'MIT',
+ 'author': '',
+ 'author_email': 'Frost Ming <mianghong@gmail.com>,Sébastien Eustace <sebastien@eustace.io>',
+ 'maintainer': None,
+ 'maintainer_email': None,
+ 'url': '',
+ 'packages': [
+ 'atoml',
+ ],
+ 'package_data': {'': ['*']},
+ 'long_description_content_type': 'text/markdown',
+ 'classifiers': [
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ ],
+ 'python_requires': '>=3.6',
+
+}
+
+
+setup(**setup_kwargs)
diff --git a/textproc/py-atoml/pkg-descr b/textproc/py-atoml/pkg-descr
new file mode 100644
index 000000000000..243400d7e447
--- /dev/null
+++ b/textproc/py-atoml/pkg-descr
@@ -0,0 +1,9 @@
+ATOML is a 1.0.0rc1-compliant TOML library.
+
+It includes a parser that preserves all comments, indentations, whitespace and
+internal element ordering, and makes them accessible and editable via an
+intuitive API.
+
+You can also create new TOML documents from scratch using the provided helpers.
+
+WWW: https://github.com/frostming/atoml