aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-chardet
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-03-05 04:05:33 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-03-05 04:05:33 +0000
commit4f997fefc580bc67c2df6d067901e21aed042e99 (patch)
tree65e26f5191ee663ed3775e1f8a63e21bee837879 /textproc/py-chardet
parentc4bf0bd0e7c2484045d0ea937d1d3d8f00ae9253 (diff)
downloadports-4f997fefc580bc67c2df6d067901e21aed042e99.tar.gz
ports-4f997fefc580bc67c2df6d067901e21aed042e99.zip
Notes
Diffstat (limited to 'textproc/py-chardet')
-rw-r--r--textproc/py-chardet/Makefile12
-rw-r--r--textproc/py-chardet/distinfo4
-rw-r--r--textproc/py-chardet/files/patch-setup.py11
-rw-r--r--textproc/py-chardet/files/patch-test.py16
4 files changed, 39 insertions, 4 deletions
diff --git a/textproc/py-chardet/Makefile b/textproc/py-chardet/Makefile
index 6f6d58cc9b70..f47b3da9fe3c 100644
--- a/textproc/py-chardet/Makefile
+++ b/textproc/py-chardet/Makefile
@@ -3,8 +3,8 @@
PORTNAME= chardet
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= textproc python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rm@FreeBSD.org
@@ -13,7 +13,15 @@ COMMENT= Universal encoding detector for Python 2 and 3
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
USES= python
-USE_PYTHON= autoplist distutils
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/textproc/py-chardet/distinfo b/textproc/py-chardet/distinfo
index d3c1414e6dea..2ef2830c9b19 100644
--- a/textproc/py-chardet/distinfo
+++ b/textproc/py-chardet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chardet-2.3.0.tar.gz) = e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa
-SIZE (chardet-2.3.0.tar.gz) = 164346
+SHA256 (chardet-chardet-2.3.0_GH0.tar.gz) = afb95679fb687fad167a714d929d033e3dd0d64b66d3646eecf117d350ae40cc
+SIZE (chardet-chardet-2.3.0_GH0.tar.gz) = 2035957
diff --git a/textproc/py-chardet/files/patch-setup.py b/textproc/py-chardet/files/patch-setup.py
new file mode 100644
index 000000000000..3ab9ce49e60c
--- /dev/null
+++ b/textproc/py-chardet/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2014-10-07 15:03:14 UTC
++++ setup.py
+@@ -36,4 +36,7 @@ setup(name='chardet',
+ "Modules"),
+ "Topic :: Text Processing :: Linguistic"],
+ packages=['chardet'],
+- entry_points={'console_scripts': ['chardetect = chardet.chardetect:main']})
++ entry_points={'console_scripts': ['chardetect = chardet.chardetect:main']},
++ tests_require=['nose'],
++ test_suite='nose.collector',
++)
diff --git a/textproc/py-chardet/files/patch-test.py b/textproc/py-chardet/files/patch-test.py
new file mode 100644
index 000000000000..38cb50351193
--- /dev/null
+++ b/textproc/py-chardet/files/patch-test.py
@@ -0,0 +1,16 @@
+--- test.py.orig 2014-10-07 15:03:14 UTC
++++ test.py
+@@ -36,11 +36,8 @@ class TestCase(unittest.TestCase):
+
+ def main():
+ suite = unittest.TestSuite()
+- if len(sys.argv) > 1:
+- base_path = sys.argv[1]
+- else:
+- base_path = os.path.join(
+- os.path.dirname(os.path.abspath(__file__)), 'tests')
++ base_path = os.path.join(
++ os.path.dirname(os.path.abspath(__file__)), 'tests')
+ for encoding in os.listdir(base_path):
+ path = os.path.join(base_path, encoding)
+ if not os.path.isdir(path):