aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-docutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-27 19:12:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-27 19:12:20 +0000
commit73b34244ca91b5857181d47184870afef6b9622d (patch)
tree3f9adb28e724634899d623ca4633d4a53ce3c94b /textproc/py-docutils
parentb4b2c6ea4595438388a3e53a86af30e86289d3f1 (diff)
Notes
Diffstat (limited to 'textproc/py-docutils')
-rw-r--r--textproc/py-docutils/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/textproc/py-docutils/Makefile b/textproc/py-docutils/Makefile
index 7697e6119b01..a8e20638d59f 100644
--- a/textproc/py-docutils/Makefile
+++ b/textproc/py-docutils/Makefile
@@ -4,8 +4,7 @@
PORTNAME= docutils
PORTVERSION= 0.13.1
CATEGORIES= textproc python
-MASTER_SITES= SF \
- CHEESESHOP
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
@@ -14,21 +13,20 @@ COMMENT= Python Documentation Utilities
LICENSE= BSD2CLAUSE GPLv3+ PD PSFL
LICENSE_COMB= multi
-USES= python
-USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
OPTIONS_DEFINE= PYGMENTS
-PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
PYGMENTS_DESC= Syntax highlighting
+PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
-BIN_SCRIPTS= rst2html.py rst2s5.py rst2latex.py rst2xetex.py \
- rst2man.py rst2xml.py rst2pseudoxml.py rstpep2html.py \
- rst2odt.py rst2odt_prepstyles.py
+SCRIPTS= rst2html rst2latex rst2man rst2odt rst2odt_prepstyles \
+ rst2pseudoxml rst2s5 rst2xetex rst2xml rstpep2html
post-install:
-.for script in ${BIN_SCRIPTS}
- @cd ${STAGEDIR}${PREFIX}/bin && ${LN} -sf ${script} ${script:C/\.py//}
+.for script in ${SCRIPTS}
+ ${LN} -s ${script}.py ${STAGEDIR}${PREFIX}/bin/${script}
.endfor
.include <bsd.port.mk>