aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-elasticsearch
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-24 17:38:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-24 17:38:37 +0000
commit034306ab76d5d8c27d93f3ca7d8b44138b33b4e7 (patch)
tree4ba0a72534fbe48a5527fe7ce15e69a4adcd2640 /textproc/py-elasticsearch
parent7315f05c160df8f28442469f20a5610e19860bf1 (diff)
downloadports-034306ab76d5d8c27d93f3ca7d8b44138b33b4e7.tar.gz
ports-034306ab76d5d8c27d93f3ca7d8b44138b33b4e7.zip
Add ASYNC option
Notes
Notes: svn path=/head/; revision=540093
Diffstat (limited to 'textproc/py-elasticsearch')
-rw-r--r--textproc/py-elasticsearch/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/textproc/py-elasticsearch/Makefile b/textproc/py-elasticsearch/Makefile
index 858066b06848..21f443f0eac6 100644
--- a/textproc/py-elasticsearch/Makefile
+++ b/textproc/py-elasticsearch/Makefile
@@ -27,10 +27,13 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= REQUESTS
+OPTIONS_DEFINE= ASYNC REQUESTS
OPTIONS_DEFAULT=REQUESTS
+ASYNC_DESC= Asynchronous support
REQUESTS_DESC= Enable requests support
+ASYNC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3<4:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yarl>=0:www/py-yarl@${PY_FLAVOR}
REQUESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.0<3.0.0:www/py-requests@${PY_FLAVOR}
.include <bsd.port.mk>