aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-enchant/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-06 15:05:08 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-06 15:05:08 +0000
commit43cf76f912ce50cae43d4b9796f0b951f244907c (patch)
tree2cc083d5937c511bdc22f42aace6bc2a822eb6fe /textproc/py-enchant/Makefile
parentad5ac491b1fb3873adf97452e230bfbc0ebafeed (diff)
Notes
Diffstat (limited to 'textproc/py-enchant/Makefile')
-rw-r--r--textproc/py-enchant/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/py-enchant/Makefile b/textproc/py-enchant/Makefile
new file mode 100644
index 000000000000..f609a3526fe2
--- /dev/null
+++ b/textproc/py-enchant/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-enchant
+# Date created: 2006-04-03
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= enchant
+PORTVERSION= 1.1.5
+CATEGORIES= textproc devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= py${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${MASTER_SITE_SUBDIR}-${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= A spellchecking library for Python based on the Enchant library
+
+LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_INSTALL_TARGET= install_lib
+PYDISTUTILS_INSTALLARGS=
+
+MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>