aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-excelerator/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 12:09:56 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 12:09:56 +0000
commitc2a049a09cfc57aef7a8fa4d1452c5ef43ed4257 (patch)
tree431166dd1179ef38afb6c700015efcf7dae2c414 /textproc/py-excelerator/Makefile
parent3cfd56599484fc7e3118196115d944173681f645 (diff)
downloadports-c2a049a09cfc57aef7a8fa4d1452c5ef43ed4257.tar.gz
ports-c2a049a09cfc57aef7a8fa4d1452c5ef43ed4257.zip
Notes
Diffstat (limited to 'textproc/py-excelerator/Makefile')
-rw-r--r--textproc/py-excelerator/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/py-excelerator/Makefile b/textproc/py-excelerator/Makefile
new file mode 100644
index 000000000000..b941b089bd42
--- /dev/null
+++ b/textproc/py-excelerator/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: py-excelerator
+# Date created: 13 May 2005
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= excelerator
+PORTVERSION= 0.5.0a
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyexcelerator
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyExcelerator-${PORTVERSION}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= A Python library for generating Excel 97/2000/XP/2003 files
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+USE_ZIP= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES.txt LICENSE.txt README.txt THANKS.txt TODO.txt
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+ @${MKDIR} ${EXAMPLESDIR}
+ @${FIND} ${WRKSRC}/examples -type f -depth 1 -exec ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+
+.include <bsd.port.mk>