aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-feedparser
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2013-07-18 13:26:16 +0000
committerSofian Brabez <sbz@FreeBSD.org>2013-07-18 13:26:16 +0000
commit2a10efd6ece9411d4273799fe5db88840b040da9 (patch)
treebcfa82c7685895c7ec933567e13dc797d668dd72 /textproc/py-feedparser
parent4b40efa19ea62dfc8f19e6819b86356e9825631c (diff)
downloadports-2a10efd6ece9411d4273799fe5db88840b040da9.tar.gz
ports-2a10efd6ece9411d4273799fe5db88840b040da9.zip
- Convert new option framework
- Respect PORTDOCS - Update RUN_DEPENDS
Notes
Notes: svn path=/head/; revision=323231
Diffstat (limited to 'textproc/py-feedparser')
-rw-r--r--textproc/py-feedparser/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
index 3fec3f928999..d0e9f944d2bd 100644
--- a/textproc/py-feedparser/Makefile
+++ b/textproc/py-feedparser/Makefile
@@ -8,25 +8,29 @@ MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sbz@FreeBSD.org
-COMMENT= An RSS feed parser written in Python
+COMMENT= RSS feed parser written in Python
LICENSE= BSD
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/chardet/__init__.py:${PORTSDIR}/textproc/py-chardet
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>0:${PORTSDIR}/textproc/py-chardet
USE_PYTHON= yes
USE_BZIP2= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
+
+OPTIONS_DEFINE= DOCS
PORTDOCS= NEWS PKG-INFO README
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-regression-test:
- @(cd ${WRKSRC}/${PORTNAME} && ${PYTHON_CMD} ${PORTNAME}test.py)
+regression-test: extract
+ @(cd ${WRKSRC}/${PORTNAME}; ${PYTHON_CMD} ${PORTNAME}test.py)
.include <bsd.port.mk>