aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-feedparser
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-18 21:53:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-18 21:53:47 +0000
commit521f7d71055a1de35928d6832a9884bb31d71cc0 (patch)
tree303d1f2670ae15c771a59e10e104dad239006054 /textproc/py-feedparser
parent44978d4dcff8c109578bf5c2b9f7f474fcd755e5 (diff)
downloadports-521f7d71055a1de35928d6832a9884bb31d71cc0.tar.gz
ports-521f7d71055a1de35928d6832a9884bb31d71cc0.zip
Notes
Diffstat (limited to 'textproc/py-feedparser')
-rw-r--r--textproc/py-feedparser/Makefile10
-rw-r--r--textproc/py-feedparser/distinfo5
-rw-r--r--textproc/py-feedparser/pkg-plist88
3 files changed, 57 insertions, 46 deletions
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
index 4df68a089caf..285450e5e9e8 100644
--- a/textproc/py-feedparser/Makefile
+++ b/textproc/py-feedparser/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= feedparser
-PORTVERSION= 3.3
+PORTVERSION= 4.1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://bsdchat.com/dist/dryice/
@@ -17,7 +17,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= dryice@dryice.name
COMMENT= An RSS feed parser written in Python
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}
USE_PYTHON= 2.1+
USE_ZIP= yes
USE_PYDISTUTILS= yes
@@ -28,9 +28,11 @@ post-install:
.for i in *.html
@${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
.endfor
- @${MKDIR} ${DOCSDIR}/images
+.for j in images css examples
+ @${MKDIR} ${DOCSDIR}/${j}
.for i in *
- @${INSTALL_DATA} ${WRKSRC}/docs/images/${i} ${DOCSDIR}/images
+ @${INSTALL_DATA} ${WRKSRC}/docs/${j}/${i} ${DOCSDIR}/${j}
+.endfor
.endfor
.endif
diff --git a/textproc/py-feedparser/distinfo b/textproc/py-feedparser/distinfo
index 269ec1acf903..c46ea7b547b0 100644
--- a/textproc/py-feedparser/distinfo
+++ b/textproc/py-feedparser/distinfo
@@ -1,2 +1,3 @@
-MD5 (feedparser-3.3.zip) = f95db0d0e8832197c40a90f517546e21
-SIZE (feedparser-3.3.zip) = 255518
+MD5 (feedparser-4.1.zip) = 7ab1140c1e29d4cd52ab20fa7b1f8640
+SHA256 (feedparser-4.1.zip) = b1d8052b130f52e67501bdac269efad1f813ee8b4ff2b5c0f5d72f1286322167
+SIZE (feedparser-4.1.zip) = 258511
diff --git a/textproc/py-feedparser/pkg-plist b/textproc/py-feedparser/pkg-plist
index 2c7228e57cab..0dd86e90a214 100644
--- a/textproc/py-feedparser/pkg-plist
+++ b/textproc/py-feedparser/pkg-plist
@@ -1,14 +1,9 @@
-%%PYTHON_SITELIBDIR%%/feedparser.py
-%%PYTHON_SITELIBDIR%%/feedparser.pyc
-%%PYTHON_SITELIBDIR%%/feedparser.pyo
-%%PORTDOCS%%%%DOCSDIR%%/images/caution.png
-%%PORTDOCS%%%%DOCSDIR%%/images/important.png
-%%PORTDOCS%%%%DOCSDIR%%/images/note.png
-%%PORTDOCS%%%%DOCSDIR%%/images/permalink.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/tip.png
-%%PORTDOCS%%%%DOCSDIR%%/images/warning.png
+lib/python2.4/site-packages/feedparser.py
+lib/python2.4/site-packages/feedparser.pyc
+lib/python2.4/site-packages/feedparser.pyo
%%PORTDOCS%%%%DOCSDIR%%/advanced.html
-%%PORTDOCS%%%%DOCSDIR%%/annotated-atom.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-atom03.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-atom10.html
%%PORTDOCS%%%%DOCSDIR%%/annotated-examples.html
%%PORTDOCS%%%%DOCSDIR%%/annotated-rss10.html
%%PORTDOCS%%%%DOCSDIR%%/annotated-rss20-dc.html
@@ -17,24 +12,27 @@
%%PORTDOCS%%%%DOCSDIR%%/basic-existence.html
%%PORTDOCS%%%%DOCSDIR%%/basic.html
%%PORTDOCS%%%%DOCSDIR%%/bozo.html
+%%PORTDOCS%%%%DOCSDIR%%/changes-40.html
+%%PORTDOCS%%%%DOCSDIR%%/changes-41.html
%%PORTDOCS%%%%DOCSDIR%%/character-encoding.html
%%PORTDOCS%%%%DOCSDIR%%/common-atom-elements.html
%%PORTDOCS%%%%DOCSDIR%%/common-rss-elements.html
%%PORTDOCS%%%%DOCSDIR%%/content-normalization.html
+%%PORTDOCS%%%%DOCSDIR%%/css/feedparser.css
%%PORTDOCS%%%%DOCSDIR%%/date-parsing.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-aggregation.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-applicability.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-collections.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-combining.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-copying.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-copyinginquantity.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-future.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-howto.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-modifications.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-preamble.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-termination.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl-translation.html
-%%PORTDOCS%%%%DOCSDIR%%/gfdl.html
+%%PORTDOCS%%%%DOCSDIR%%/examples/atom03.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/atom10.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/base.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/basic_auth.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/digest_auth.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/http_base.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/no_base.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/nonstandard_prefix.rdf
+%%PORTDOCS%%%%DOCSDIR%%/examples/prism.rdf
+%%PORTDOCS%%%%DOCSDIR%%/examples/rss10.rdf
+%%PORTDOCS%%%%DOCSDIR%%/examples/rss20.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/rss20dc.xml
+%%PORTDOCS%%%%DOCSDIR%%/history.html
%%PORTDOCS%%%%DOCSDIR%%/html-sanitization.html
%%PORTDOCS%%%%DOCSDIR%%/http-authentication.html
%%PORTDOCS%%%%DOCSDIR%%/http-etag.html
@@ -42,53 +40,56 @@
%%PORTDOCS%%%%DOCSDIR%%/http-redirect.html
%%PORTDOCS%%%%DOCSDIR%%/http-useragent.html
%%PORTDOCS%%%%DOCSDIR%%/http.html
+%%PORTDOCS%%%%DOCSDIR%%/images/caution.png
+%%PORTDOCS%%%%DOCSDIR%%/images/important.png
+%%PORTDOCS%%%%DOCSDIR%%/images/note.png
+%%PORTDOCS%%%%DOCSDIR%%/images/permalink.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/tip.png
+%%PORTDOCS%%%%DOCSDIR%%/images/warning.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
%%PORTDOCS%%%%DOCSDIR%%/namespace-handling.html
%%PORTDOCS%%%%DOCSDIR%%/reference-bozo.html
%%PORTDOCS%%%%DOCSDIR%%/reference-bozo_exception.html
%%PORTDOCS%%%%DOCSDIR%%/reference-encoding.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-author.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-author_detail.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-categories.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-category.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-comments.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-content.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-contributors.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-created.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-created_parsed.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-enclosure.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-enclosures.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-expired.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-expired_parsed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-id.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-issued.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-issued_parsed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-license.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-link.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-links.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-modified.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-entry-modified_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-published.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-published_parsed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-publisher.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-publisher_detail.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-source.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-summary.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-summary_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-tags.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-title.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry-title_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-updated.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-updated_parsed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-entry.html
%%PORTDOCS%%%%DOCSDIR%%/reference-etag.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-author.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-author_detail.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-categories.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-category.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-cloud.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-contributors.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-copyright.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-copyright_detail.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-docs.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-errorreportsto.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-generator.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-generator_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-icon.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-id.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-image.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-info-detail.html
@@ -97,26 +98,33 @@
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-license.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-link.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-links.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-modified.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-modified_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-logo.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-publisher.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-publisher_detail.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-tagline.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-feed-tagline_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-rights.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-rights_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-subtitle.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-subtitle_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-tags.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-textinput.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-title.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-title_detail.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed-ttl.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-updated.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-updated_parsed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-feed.html
%%PORTDOCS%%%%DOCSDIR%%/reference-headers.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-href.html
%%PORTDOCS%%%%DOCSDIR%%/reference-modified.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-namespaces.html
%%PORTDOCS%%%%DOCSDIR%%/reference-status.html
-%%PORTDOCS%%%%DOCSDIR%%/reference-url.html
%%PORTDOCS%%%%DOCSDIR%%/reference-version.html
%%PORTDOCS%%%%DOCSDIR%%/reference.html
%%PORTDOCS%%%%DOCSDIR%%/resolving-relative-links.html
%%PORTDOCS%%%%DOCSDIR%%/uncommon-atom.html
%%PORTDOCS%%%%DOCSDIR%%/uncommon-rss.html
%%PORTDOCS%%%%DOCSDIR%%/version-detection.html
-%%PORTDOCS%%@dirrm %%PORTDOCS%%%%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/css
%%PORTDOCS%%@dirrm %%DOCSDIR%%