aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-feedparser
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-04-08 12:21:06 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-04-08 12:21:06 +0000
commitc811d30ed93243459b5c6c3bba411a00e3b4bc86 (patch)
tree758d3a95b1273f9ca7053acacceb1eeb54180b96 /textproc/py-feedparser
parent9afe2bb0705d650dd58e2b6a1fbc585be7547818 (diff)
downloadports-c811d30ed93243459b5c6c3bba411a00e3b4bc86.tar.gz
ports-c811d30ed93243459b5c6c3bba411a00e3b4bc86.zip
- Install docs
- Require Python 2.1+ - Additional mirror MASTER_SITE - Pass maintainership to submitter PR: 79582 Submitted by: Dryice Liu <dryice@liu.com.cn>
Notes
Notes: svn path=/head/; revision=132752
Diffstat (limited to 'textproc/py-feedparser')
-rw-r--r--textproc/py-feedparser/Makefile19
-rw-r--r--textproc/py-feedparser/pkg-plist119
2 files changed, 135 insertions, 3 deletions
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
index c37d5a45fe58..1172c137bb05 100644
--- a/textproc/py-feedparser/Makefile
+++ b/textproc/py-feedparser/Makefile
@@ -9,16 +9,29 @@
PORTNAME= feedparser
PORTVERSION= 3.3
CATEGORIES= textproc python
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://bsdchat.com/dist/dryice/
MASTER_SITE_SUBDIR= feedparser
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dryice@liu.com.cn
COMMENT= An RSS feed parser written in Python
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PYTHON= yes
+USE_PYTHON= 2.1+
USE_ZIP= yes
USE_PYDISTUTILS= yes
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in *.html
+ @${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${DOCSDIR}/images
+.for i in *
+ @${INSTALL_DATA} ${WRKSRC}/docs/images/${i} ${DOCSDIR}/images
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/py-feedparser/pkg-plist b/textproc/py-feedparser/pkg-plist
index b2c30d62fbdf..2c7228e57cab 100644
--- a/textproc/py-feedparser/pkg-plist
+++ b/textproc/py-feedparser/pkg-plist
@@ -1,3 +1,122 @@
%%PYTHON_SITELIBDIR%%/feedparser.py
%%PYTHON_SITELIBDIR%%/feedparser.pyc
%%PYTHON_SITELIBDIR%%/feedparser.pyo
+%%PORTDOCS%%%%DOCSDIR%%/images/caution.png
+%%PORTDOCS%%%%DOCSDIR%%/images/important.png
+%%PORTDOCS%%%%DOCSDIR%%/images/note.png
+%%PORTDOCS%%%%DOCSDIR%%/images/permalink.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/tip.png
+%%PORTDOCS%%%%DOCSDIR%%/images/warning.png
+%%PORTDOCS%%%%DOCSDIR%%/advanced.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-atom.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-examples.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-rss10.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-rss20-dc.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated-rss20.html
+%%PORTDOCS%%%%DOCSDIR%%/atom-detail.html
+%%PORTDOCS%%%%DOCSDIR%%/basic-existence.html
+%%PORTDOCS%%%%DOCSDIR%%/basic.html
+%%PORTDOCS%%%%DOCSDIR%%/bozo.html
+%%PORTDOCS%%%%DOCSDIR%%/character-encoding.html
+%%PORTDOCS%%%%DOCSDIR%%/common-atom-elements.html
+%%PORTDOCS%%%%DOCSDIR%%/common-rss-elements.html
+%%PORTDOCS%%%%DOCSDIR%%/content-normalization.html
+%%PORTDOCS%%%%DOCSDIR%%/date-parsing.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-aggregation.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-applicability.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-collections.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-combining.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-copying.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-copyinginquantity.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-future.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-howto.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-modifications.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-preamble.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-termination.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl-translation.html
+%%PORTDOCS%%%%DOCSDIR%%/gfdl.html
+%%PORTDOCS%%%%DOCSDIR%%/html-sanitization.html
+%%PORTDOCS%%%%DOCSDIR%%/http-authentication.html
+%%PORTDOCS%%%%DOCSDIR%%/http-etag.html
+%%PORTDOCS%%%%DOCSDIR%%/http-other.html
+%%PORTDOCS%%%%DOCSDIR%%/http-redirect.html
+%%PORTDOCS%%%%DOCSDIR%%/http-useragent.html
+%%PORTDOCS%%%%DOCSDIR%%/http.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/namespace-handling.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-bozo.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-bozo_exception.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-encoding.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-author.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-author_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-categories.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-category.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-comments.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-content.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-contributors.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-created.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-created_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-enclosure.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-expired.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-expired_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-id.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-issued.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-issued_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-license.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-link.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-links.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-modified.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-modified_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-publisher.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-publisher_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-source.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-summary_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-title.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry-title_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-entry.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-etag.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-author.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-author_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-categories.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-category.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-cloud.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-contributors.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-copyright_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-docs.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-errorreportsto.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-generator.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-generator_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-id.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-image.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-info-detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-info.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-language.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-license.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-link.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-links.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-modified.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-modified_parsed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-publisher.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-publisher_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-tagline.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-tagline_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-textinput.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-title.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-title_detail.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed-ttl.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-feed.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-headers.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-modified.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-status.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-url.html
+%%PORTDOCS%%%%DOCSDIR%%/reference-version.html
+%%PORTDOCS%%%%DOCSDIR%%/reference.html
+%%PORTDOCS%%%%DOCSDIR%%/resolving-relative-links.html
+%%PORTDOCS%%%%DOCSDIR%%/uncommon-atom.html
+%%PORTDOCS%%%%DOCSDIR%%/uncommon-rss.html
+%%PORTDOCS%%%%DOCSDIR%%/version-detection.html
+%%PORTDOCS%%@dirrm %%PORTDOCS%%%%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%