aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-genshi/files/patch-setup.py
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:21:47 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:21:47 +0000
commit55c3fef16a049a86bc68a659c112a7b020e3fd49 (patch)
treea6bc1949682b6802c9fe43187bd71cd84011b1d5 /textproc/py-genshi/files/patch-setup.py
parent53f70e684d29a9a4a557b49bc757884080bd9216 (diff)
downloadports-55c3fef16a049a86bc68a659c112a7b020e3fd49.tar.gz
ports-55c3fef16a049a86bc68a659c112a7b020e3fd49.zip
MFH: r520212 textproc/py-genshi: Update to 0.7.3
Genshi 0.7 doesn't support Python 3.5+, but the port currently allows it to be built with any Python version. This doesn't affect the build, but produces a broken runtime, including for all Genshi dependents: Genshi (0.7) tests: 2.7: Ran 854 tests in 3.623s - FAILED (failures=1) 3.5: Ran 858 tests in 3.607s - FAILED (failures=4, errors=34) 3.6: Ran 858 tests in 3.610s - FAILED (failures=4, errors=34) 3.7: Ran 858 tests in 3.313s - FAILED (failures=11, errors=91) 3.8: Ran 858 tests in 3.094s - FAILED (failures=32, errors=359) Genshi added 3.5+ support in subsequent versions [1]: 0.7.2: Add support for Python 3.8. 0.7.1: Add support for Python 3.5, 3.6 and 3.7 Given Genshi 0.7 -> 0.7.3 involves only additional Python version support and bugfix-only changes, this change updates the port to 0.7.3, instead of restricting (correctly) its use to USES=python:-3.4, and is intended to be merged to the quarterly branch accordingly. While I'm here: - Add test target to encourage and ease future QA - Strip speedup shared library on Python versions it builds in - Remove backported patch to setup.py (now in this release) - Use CHEESESHOP and update COMMENT according to Python policies Genshi (0.7.3) QA tests: 2.7: Ran 861 tests in 3.626s - OK 3.5: Ran 867 tests in 3.561s - OK 3.6: Ran 867 tests in 3.540s - OK 3.7: Ran 867 tests in 3.268s - OK 3.8: Ran 867 tests in 3.267s - OK [1] https://github.com/edgewall/genshi/blob/0.7.3/ChangeLog Approved by: portmgr (blanket(s): runtime bugfix, ports (python) compliance) Approved by: ports-secteam (blanket(s): runtime bugfix, bugfix release)
Notes
Notes: svn path=/branches/2019Q4/; revision=520496
Diffstat (limited to 'textproc/py-genshi/files/patch-setup.py')
-rw-r--r--textproc/py-genshi/files/patch-setup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/textproc/py-genshi/files/patch-setup.py b/textproc/py-genshi/files/patch-setup.py
deleted file mode 100644
index 57166f1c6c15..000000000000
--- a/textproc/py-genshi/files/patch-setup.py
+++ /dev/null
@@ -1,17 +0,0 @@
---- setup.py.orig 2013-01-27 15:48:03 UTC
-+++ setup.py
-@@ -65,9 +65,13 @@ available.""")
-
-
- if Feature:
-+ # Optional C extension module for speeding up Genshi:
-+ # Not activated by default on:
-+ # - PyPy (where it harms performance)
-+ # - CPython >= 3.3 (the new Unicode C API is not supported yet)
- speedups = Feature(
- "optional C speed-enhancements",
-- standard = not is_pypy,
-+ standard = not is_pypy and sys.version_info < (3, 3),
- ext_modules = [
- Extension('genshi._speedups', ['genshi/_speedups.c']),
- ],