aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-libxml2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-05-13 20:32:00 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-05-13 20:32:00 +0000
commit607eebc44b493d9a5325cbbc6e4f310408e9fc37 (patch)
treeaf5d54de867e1999ce3c9a27fc7b84393b692520 /textproc/py-libxml2
parent8c30535693f76b75884fe7a3f37980252601f194 (diff)
downloadports-607eebc44b493d9a5325cbbc6e4f310408e9fc37.tar.gz
ports-607eebc44b493d9a5325cbbc6e4f310408e9fc37.zip
Notes
Diffstat (limited to 'textproc/py-libxml2')
-rw-r--r--textproc/py-libxml2/Makefile9
-rw-r--r--textproc/py-libxml2/pkg-plist55
2 files changed, 5 insertions, 59 deletions
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index 2022fac33493..bd58792b2d13 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -1,7 +1,8 @@
# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
+# $MCom: ports/trunk/textproc/py-libxml2/Makefile 18999 2014-02-04 18:55:27Z kwm $
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= textproc gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,9 @@ PLIST= ${.CURDIR}/pkg-plist
USE_GNOME+= libxml2
USE_PYTHON= 2
-USES= iconv
+USE_PYDISTUTILS=yes
+PYDISTUTILS_EGGINFO= libxml2_python-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
@@ -28,8 +31,6 @@ DOCSDIR= ${PREFIX}/share/doc/py-libxml2
EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
post-install:
- @cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
- @cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/py-libxml2/pkg-plist b/textproc/py-libxml2/pkg-plist
index bfa1da59c6a8..9c9155aa22c6 100644
--- a/textproc/py-libxml2/pkg-plist
+++ b/textproc/py-libxml2/pkg-plist
@@ -4,59 +4,4 @@
%%PYTHON_SITELIBDIR%%/libxml2.py
%%PYTHON_SITELIBDIR%%/libxml2.pyc
%%PYTHON_SITELIBDIR%%/libxml2.pyo
-%%PYTHON_SITELIBDIR%%/libxml2mod.a
-%%PYTHON_SITELIBDIR%%/libxml2mod.la
%%PYTHON_SITELIBDIR%%/libxml2mod.so
-%%DOCSDIR%%/TODO
-%%EXAMPLESDIR%%/attribs.py
-%%EXAMPLESDIR%%/build.py
-%%EXAMPLESDIR%%/compareNodes.py
-%%EXAMPLESDIR%%/ctxterror.py
-%%EXAMPLESDIR%%/cutnpaste.py
-%%EXAMPLESDIR%%/dtdvalid.py
-%%EXAMPLESDIR%%/error.py
-%%EXAMPLESDIR%%/inbuf.py
-%%EXAMPLESDIR%%/indexes.py
-%%EXAMPLESDIR%%/invalid.xml
-%%EXAMPLESDIR%%/nsdel.py
-%%EXAMPLESDIR%%/outbuf.py
-%%EXAMPLESDIR%%/push.py
-%%EXAMPLESDIR%%/pushSAX.py
-%%EXAMPLESDIR%%/pushSAXhtml.py
-%%EXAMPLESDIR%%/reader.py
-%%EXAMPLESDIR%%/reader2.py
-%%EXAMPLESDIR%%/reader3.py
-%%EXAMPLESDIR%%/reader4.py
-%%EXAMPLESDIR%%/reader5.py
-%%EXAMPLESDIR%%/reader6.py
-%%EXAMPLESDIR%%/reader7.py
-%%EXAMPLESDIR%%/reader8.py
-%%EXAMPLESDIR%%/readererr.py
-%%EXAMPLESDIR%%/readernext.py
-%%EXAMPLESDIR%%/regexp.py
-%%EXAMPLESDIR%%/relaxng.py
-%%EXAMPLESDIR%%/resolver.py
-%%EXAMPLESDIR%%/schema.py
-%%EXAMPLESDIR%%/serialize.py
-%%EXAMPLESDIR%%/sync.py
-%%EXAMPLESDIR%%/test.dtd
-%%EXAMPLESDIR%%/thread2.py
-%%EXAMPLESDIR%%/tst.py
-%%EXAMPLESDIR%%/tst.xml
-%%EXAMPLESDIR%%/tstLastError.py
-%%EXAMPLESDIR%%/tstURI.py
-%%EXAMPLESDIR%%/tstmem.py
-%%EXAMPLESDIR%%/tstxpath.py
-%%EXAMPLESDIR%%/valid.xml
-%%EXAMPLESDIR%%/validDTD.py
-%%EXAMPLESDIR%%/validRNG.py
-%%EXAMPLESDIR%%/validSchemas.py
-%%EXAMPLESDIR%%/validate.py
-%%EXAMPLESDIR%%/walker.py
-%%EXAMPLESDIR%%/xpath.py
-%%EXAMPLESDIR%%/xpathext.py
-%%EXAMPLESDIR%%/xpathleak.py
-%%EXAMPLESDIR%%/xpathns.py
-%%EXAMPLESDIR%%/xpathret.py
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%