aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-libxslt/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:07:06 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:07:06 +0000
commit3e9d8c17f6eab55b966cdfe21ca2ccb168e9728b (patch)
treebcf74f4f1b5fafedeafc598e509da918633dd97b /textproc/py-libxslt/Makefile
parenta89f7de8a83341764d2b0d1a201c469664e378f7 (diff)
downloadports-3e9d8c17f6eab55b966cdfe21ca2ccb168e9728b.tar.gz
ports-3e9d8c17f6eab55b966cdfe21ca2ccb168e9728b.zip
Notes
Diffstat (limited to 'textproc/py-libxslt/Makefile')
-rw-r--r--textproc/py-libxslt/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/py-libxslt/Makefile b/textproc/py-libxslt/Makefile
new file mode 100644
index 000000000000..ed3bd5e871d9
--- /dev/null
+++ b/textproc/py-libxslt/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-libxslt
+# Date created: 2 Jun 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface for XSLT C library for GNOME
+
+MASTERDIR= ${.CURDIR}/../libxslt
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack lthack gnometarget libxslt
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --with-python=${LOCALBASE}
+
+DOCSDIR= ${PREFIX}/share/doc/py-libxslt
+EXAMPLESDIR= ${PREFIX}/share/examples/py-libxslt
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"