aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-python-gettext
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-01-16 13:23:40 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-01-16 13:23:40 +0000
commit28242ae8330c20b1a3466dfee790bc6012dd2b89 (patch)
tree1c43e1ac104bbc2a794324971eecd6122d44fb17 /textproc/py-python-gettext
parentb64c9907db18af488108440ec2ddcb77e9d53b0c (diff)
downloadports-28242ae8330c20b1a3466dfee790bc6012dd2b89.tar.gz
ports-28242ae8330c20b1a3466dfee790bc6012dd2b89.zip
Notes
Diffstat (limited to 'textproc/py-python-gettext')
-rw-r--r--textproc/py-python-gettext/Makefile24
-rw-r--r--textproc/py-python-gettext/distinfo2
-rw-r--r--textproc/py-python-gettext/pkg-descr5
3 files changed, 31 insertions, 0 deletions
diff --git a/textproc/py-python-gettext/Makefile b/textproc/py-python-gettext/Makefile
new file mode 100644
index 000000000000..68c2e8b433f2
--- /dev/null
+++ b/textproc/py-python-gettext/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= python-gettext
+PORTVERSION= 2.1
+PORTREVISION= 1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Python Gettext po to mo file compiler
+
+LICENSE= BSD2CLAUSE
+
+USES= python zip
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} <= 3000
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>=0:${PORTSDIR}/devel/py-unittest2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/py-python-gettext/distinfo b/textproc/py-python-gettext/distinfo
new file mode 100644
index 000000000000..5028406ee426
--- /dev/null
+++ b/textproc/py-python-gettext/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-gettext-2.1.zip) = ba19fe3d2086e830f72f66617d52dc73212e3145fd545237da1f105ce5e608c5
+SIZE (python-gettext-2.1.zip) = 24193
diff --git a/textproc/py-python-gettext/pkg-descr b/textproc/py-python-gettext/pkg-descr
new file mode 100644
index 000000000000..abbd3d523a22
--- /dev/null
+++ b/textproc/py-python-gettext/pkg-descr
@@ -0,0 +1,5 @@
+This implementation of Gettext for Python includes a Msgfmt class
+which can be used to generate compiled mo files from Gettext po
+files and includes support for the newer msgctxt keyword.
+
+WWW: https://pypi.python.org/pypi/python-gettext/