aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pyx12
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-06 06:13:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-06 06:13:24 +0000
commit4504f0e90e20188328435846ec483d1ea1677ba1 (patch)
tree2e5219851ec112e0f7dea613344b5dbece92eac8 /textproc/py-pyx12
parent29220521a2bfb52784bb70d38165e6ece07a3636 (diff)
downloadports-4504f0e90e20188328435846ec483d1ea1677ba1.tar.gz
ports-4504f0e90e20188328435846ec483d1ea1677ba1.zip
Notes
Diffstat (limited to 'textproc/py-pyx12')
-rw-r--r--textproc/py-pyx12/Makefile4
-rw-r--r--textproc/py-pyx12/distinfo4
-rw-r--r--textproc/py-pyx12/files/patch-pyx12__error_handler_base.py47
-rw-r--r--textproc/py-pyx12/files/pkg-deinstall.in17
-rw-r--r--textproc/py-pyx12/pkg-descr9
5 files changed, 57 insertions, 24 deletions
diff --git a/textproc/py-pyx12/Makefile b/textproc/py-pyx12/Makefile
index 049934c5739c..bdfc0903c24a 100644
--- a/textproc/py-pyx12/Makefile
+++ b/textproc/py-pyx12/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pyx12
-PORTVERSION= 2.1.1
+PORTVERSION= 2.2.1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +12,8 @@ COMMENT= Validate and convert HIPAA X12 documents
LICENSE= BSD3CLAUSE
+NO_ARCH= yes
+
USES= python
USE_PYTHON= distutils autoplist
diff --git a/textproc/py-pyx12/distinfo b/textproc/py-pyx12/distinfo
index 73160dd6f519..4cbf502d6edb 100644
--- a/textproc/py-pyx12/distinfo
+++ b/textproc/py-pyx12/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pyx12-2.1.1.tar.gz) = 3bbd020f327e48938596a68f773c1a2324a84de2129e218008892ca1ba500d53
-SIZE (pyx12-2.1.1.tar.gz) = 499856
+SHA256 (pyx12-2.2.1.tar.gz) = 659aeb712229352113aa900f1751b80bbee1892558fbfee87f7cbc1570d65dee
+SIZE (pyx12-2.2.1.tar.gz) = 497363
diff --git a/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py b/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py
new file mode 100644
index 000000000000..bae8147ecd6a
--- /dev/null
+++ b/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py
@@ -0,0 +1,47 @@
+--- pyx12/error_handler_base.py.orig 2014-01-26 01:22:05 UTC
++++ pyx12/error_handler_base.py
+@@ -145,12 +145,18 @@ class ErrorHandlerBase(object):
+
+ @abc.abstractmethod
+ def close_isa_loop(self, node, seg, src):
++ """
++ """
+
+ @abc.abstractmethod
+ def close_gs_loop(self, node, seg, src):
++ """
++ """
+
+ @abc.abstractmethod
+ def close_st_loop(self, node, seg, src):
++ """
++ """
+
+ @abc.abstractmethod
+ def find_node(self, type):
+@@ -160,17 +166,23 @@ class ErrorHandlerBase(object):
+
+ @abc.abstractmethod
+ def _get_last_child(self):
+-
+- @abc.abstractmethod
++ """
++ """
+
+ @abc.abstractmethod
+ def get_error_count(self):
++ """
++ """
+
+ @abc.abstractmethod
+ def get_first_child(self):
++ """
++ """
+
+ @abc.abstractmethod
+ def get_next_sibling(self):
++ """
++ """
+
+ @abc.abstractmethod
+ def __next__(self):
diff --git a/textproc/py-pyx12/files/pkg-deinstall.in b/textproc/py-pyx12/files/pkg-deinstall.in
deleted file mode 100644
index 6f79ab6fb6dc..000000000000
--- a/textproc/py-pyx12/files/pkg-deinstall.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-PKGNAME=$1
-#
-case $2 in
- DEINSTALL)
- rm -f %%DATADIR%%/test/*.pyc
- rm -f %%DATADIR%%/test/*.pyo
- ;;
- POST-DEINSTALL)
- exit 0
- ;;
- *)
- echo "Unexpected Argument $2!!!"
- exit 1
- ;;
-esac
-exit 0
diff --git a/textproc/py-pyx12/pkg-descr b/textproc/py-pyx12/pkg-descr
index 9c24fc7e0578..9bcbf7055693 100644
--- a/textproc/py-pyx12/pkg-descr
+++ b/textproc/py-pyx12/pkg-descr
@@ -1,5 +1,6 @@
-pyx12 is a python based ANSI X.12 to XML EDI translator and validator. It is
-designed to be a step in the conversion of a X12 transaction to back-end
-database process. The initial target is X12N to support HIPAA transactions.
+pyx12 is a python based ANSI X.12 to XML EDI translator and validator.
+It is designed to be a step in the conversion of a X12 transaction to
+back-end database process. The initial target is X12N to support HIPAA
+transactions.
-WWW: http://pyx12.sourceforge.net/
+WWW: https://github.com/azoner/pyx12