aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pyx12
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-11 22:30:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-11 22:30:47 +0000
commit343608bb4112ee94ca8b506536c0dcc5e00b0055 (patch)
tree4b9256d4e0e33258e1b895c74384541123667743 /textproc/py-pyx12
parent326fbd5630489250ab722401ee703e68ea285863 (diff)
downloadports-343608bb4112ee94ca8b506536c0dcc5e00b0055.tar.gz
ports-343608bb4112ee94ca8b506536c0dcc5e00b0055.zip
Notes
Diffstat (limited to 'textproc/py-pyx12')
-rw-r--r--textproc/py-pyx12/Makefile27
-rw-r--r--textproc/py-pyx12/distinfo2
-rw-r--r--textproc/py-pyx12/pkg-descr5
-rw-r--r--textproc/py-pyx12/pkg-plist143
4 files changed, 177 insertions, 0 deletions
diff --git a/textproc/py-pyx12/Makefile b/textproc/py-pyx12/Makefile
new file mode 100644
index 000000000000..18954e65fe5a
--- /dev/null
+++ b/textproc/py-pyx12/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pyx12
+# Date created: 29 Jan 2004
+# Whom: john@zoner.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyx12
+PORTVERSION= 1.0.1.b3
+CATEGORIES= textproc python
+MASTER_SITES= http://osdn.dl.sourceforge.net/sourceforge/pyx12/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyx12-${PORTVERSION:S/.b/b/}
+
+MAINTAINER= john@zoner.org
+COMMENT= Validate HIPAA X12 documents
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/libxml2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+post-install:
+ ${WRKSRC}/bin/x12_build_pkl.py ${PREFIX}/share/pyx12/map/
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pyx12/distinfo b/textproc/py-pyx12/distinfo
new file mode 100644
index 000000000000..e8ef966b2a95
--- /dev/null
+++ b/textproc/py-pyx12/distinfo
@@ -0,0 +1,2 @@
+MD5 (pyx12-1.0.1b3.tar.gz) = 89da03eb54bfab6f493defc280950ffe
+SIZE (pyx12-1.0.1b3.tar.gz) = 593109
diff --git a/textproc/py-pyx12/pkg-descr b/textproc/py-pyx12/pkg-descr
new file mode 100644
index 000000000000..206993813de0
--- /dev/null
+++ b/textproc/py-pyx12/pkg-descr
@@ -0,0 +1,5 @@
+pyx12 is a python based ANSI X.12 to XML EDI translator and validator. It is
+designed to be a step in the conversion of a X12 transaction to back-end
+database process. The initial target is X12N to support HIPAA transactions.
+
+WWW: http://sourceforge.net/projects/pyx12/
diff --git a/textproc/py-pyx12/pkg-plist b/textproc/py-pyx12/pkg-plist
new file mode 100644
index 000000000000..79e21a86a506
--- /dev/null
+++ b/textproc/py-pyx12/pkg-plist
@@ -0,0 +1,143 @@
+bin/x12_build_pkl.py
+bin/x12html.py
+bin/x12lint.py
+bin/x12norm.py
+bin/x12xml.py
+%%PYTHON_SITELIBDIR%%/pyx12/__init__.py
+%%PYTHON_SITELIBDIR%%/pyx12/codes.py
+%%PYTHON_SITELIBDIR%%/pyx12/error_997.py
+%%PYTHON_SITELIBDIR%%/pyx12/error_debug.py
+%%PYTHON_SITELIBDIR%%/pyx12/error_handler.py
+%%PYTHON_SITELIBDIR%%/pyx12/error_html.py
+%%PYTHON_SITELIBDIR%%/pyx12/error_visitor.py
+%%PYTHON_SITELIBDIR%%/pyx12/errors.py
+%%PYTHON_SITELIBDIR%%/pyx12/map_if.py
+%%PYTHON_SITELIBDIR%%/pyx12/map_index.py
+%%PYTHON_SITELIBDIR%%/pyx12/map_walker.py
+%%PYTHON_SITELIBDIR%%/pyx12/params.py
+%%PYTHON_SITELIBDIR%%/pyx12/utils.py
+%%PYTHON_SITELIBDIR%%/pyx12/x12file.py
+%%PYTHON_SITELIBDIR%%/pyx12/x12n_document.py
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml.py
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_idtag.py
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_simple.py
+%%PYTHON_SITELIBDIR%%/pyx12/xmlwriter.py
+%%PYTHON_SITELIBDIR%%/pyx12/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/codes.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/error_997.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/error_debug.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/error_handler.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/error_html.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/error_visitor.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/errors.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/map_if.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/map_index.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/map_walker.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/params.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/utils.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/x12file.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/x12n_document.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_idtag.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_simple.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/xmlwriter.pyc
+%%PYTHON_SITELIBDIR%%/pyx12/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/codes.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/error_997.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/error_debug.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/error_handler.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/error_html.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/error_visitor.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/errors.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/map_if.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/map_index.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/map_walker.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/params.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/utils.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/x12file.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/x12n_document.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_idtag.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/x12xml_simple.pyo
+%%PYTHON_SITELIBDIR%%/pyx12/xmlwriter.pyo
+share/examples/pyx12/test/test.py
+share/examples/pyx12/test/test_codes.py
+share/examples/pyx12/test/test_map_if.py
+share/examples/pyx12/test/test_map_walker.py
+share/examples/pyx12/test/test_utils.py
+share/examples/pyx12/test/test_x12file.py
+share/doc/pyx12/README.txt
+share/doc/pyx12/view/Makefile
+share/doc/pyx12/view/codes.xsl
+share/doc/pyx12/view/loop.css
+share/doc/pyx12/view/loop.xsl
+share/doc/pyx12/view/map_seg.xsl
+share/doc/pyx12/view/map_sum.xsl
+share/doc/pyx12/view/seg.css
+share/doc/pyx12/view/sum.css
+share/pyx12/map/270.4010.X092.A1.xml
+share/pyx12/map/270.4010.X092.xml
+share/pyx12/map/271.4010.X092.A1.xml
+share/pyx12/map/271.4010.X092.xml
+share/pyx12/map/276.4010.X093.A1.xml
+share/pyx12/map/276.4010.X093.xml
+share/pyx12/map/277.4010.X093.A1.xml
+share/pyx12/map/277.4010.X093.xml
+share/pyx12/map/278.4010.X094.27.A1.xml
+share/pyx12/map/278.4010.X094.27.xml
+share/pyx12/map/278.4010.X094.A1.xml
+share/pyx12/map/278.4010.X094.xml
+share/pyx12/map/820.4010.X061.A1.xml
+share/pyx12/map/820.4010.X061.xml
+share/pyx12/map/834.4010.X095.A1.xml
+share/pyx12/map/835.4010.X091.A1.xml
+share/pyx12/map/835.4010.X091.xml
+share/pyx12/map/837.4010.X096.A1.xml
+share/pyx12/map/837.4010.X096.xml
+share/pyx12/map/837.4010.X097.A1.xml
+share/pyx12/map/837.4010.X097.xml
+share/pyx12/map/837.4010.X098.A1.xml
+share/pyx12/map/837.4010.X098.xml
+share/pyx12/map/841.4010.XXXC.xml
+share/pyx12/map/997.4010.xml
+share/pyx12/map/270.4010.X092.A1.pkl
+share/pyx12/map/270.4010.X092.pkl
+share/pyx12/map/271.4010.X092.A1.pkl
+share/pyx12/map/271.4010.X092.pkl
+share/pyx12/map/276.4010.X093.A1.pkl
+share/pyx12/map/276.4010.X093.pkl
+share/pyx12/map/277.4010.X093.A1.pkl
+share/pyx12/map/277.4010.X093.pkl
+share/pyx12/map/278.4010.X094.27.A1.pkl
+share/pyx12/map/278.4010.X094.27.pkl
+share/pyx12/map/278.4010.X094.A1.pkl
+share/pyx12/map/278.4010.X094.pkl
+share/pyx12/map/820.4010.X061.A1.pkl
+share/pyx12/map/820.4010.X061.pkl
+share/pyx12/map/834.4010.X095.A1.pkl
+share/pyx12/map/835.4010.X091.A1.pkl
+share/pyx12/map/835.4010.X091.pkl
+share/pyx12/map/837.4010.X096.A1.pkl
+share/pyx12/map/837.4010.X096.pkl
+share/pyx12/map/837.4010.X097.A1.pkl
+share/pyx12/map/837.4010.X097.pkl
+share/pyx12/map/837.4010.X098.A1.pkl
+share/pyx12/map/837.4010.X098.pkl
+share/pyx12/map/841.4010.XXXC.pkl
+share/pyx12/map/997.4010.pkl
+share/pyx12/map/README
+share/pyx12/map/codes.xml
+share/pyx12/map/codes.pkl
+share/pyx12/map/codes.xsd
+share/pyx12/map/comp_test.xml
+share/pyx12/map/map.xsd
+share/pyx12/map/maps.xml
+share/pyx12/map/x12.control.00401.xml
+share/pyx12/map/x12.control.00401.pkl
+@dirrm share/doc/pyx12/view
+@dirrm share/doc/pyx12
+@dirrm share/pyx12/map
+@dirrm share/pyx12
+@dirrm share/examples/pyx12/test
+@dirrm share/examples/pyx12
+@dirrm %%PYTHON_SITELIBDIR%%/pyx12