aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pyx12
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2016-09-27 03:30:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2016-09-27 03:30:30 +0000
commit546401e2fdac3382f433423b4e0381442bab98e5 (patch)
tree429acd34cc8bf32c44ba16b22c2cb6887187c2e2 /textproc/py-pyx12
parent0150cffdfd878890b5f3cc6e680226896a8acb3d (diff)
downloadports-546401e2fdac3382f433423b4e0381442bab98e5.tar.gz
ports-546401e2fdac3382f433423b4e0381442bab98e5.zip
Notes
Diffstat (limited to 'textproc/py-pyx12')
-rw-r--r--textproc/py-pyx12/Makefile2
-rw-r--r--textproc/py-pyx12/distinfo5
-rw-r--r--textproc/py-pyx12/files/patch-pyx12__error_handler_base.py47
3 files changed, 4 insertions, 50 deletions
diff --git a/textproc/py-pyx12/Makefile b/textproc/py-pyx12/Makefile
index bdfc0903c24a..dfadf6150dbf 100644
--- a/textproc/py-pyx12/Makefile
+++ b/textproc/py-pyx12/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pyx12
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/textproc/py-pyx12/distinfo b/textproc/py-pyx12/distinfo
index 4cbf502d6edb..b5dac1343166 100644
--- a/textproc/py-pyx12/distinfo
+++ b/textproc/py-pyx12/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pyx12-2.2.1.tar.gz) = 659aeb712229352113aa900f1751b80bbee1892558fbfee87f7cbc1570d65dee
-SIZE (pyx12-2.2.1.tar.gz) = 497363
+TIMESTAMP = 1474946616
+SHA256 (pyx12-2.3.1.tar.gz) = 2d29824a2eb1fab9a883780193db86d2d91d8b9305ed43f31f69951f2530158b
+SIZE (pyx12-2.3.1.tar.gz) = 522528
diff --git a/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py b/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py
deleted file mode 100644
index bae8147ecd6a..000000000000
--- a/textproc/py-pyx12/files/patch-pyx12__error_handler_base.py
+++ /dev/null
@@ -1,47 +0,0 @@
---- pyx12/error_handler_base.py.orig 2014-01-26 01:22:05 UTC
-+++ pyx12/error_handler_base.py
-@@ -145,12 +145,18 @@ class ErrorHandlerBase(object):
-
- @abc.abstractmethod
- def close_isa_loop(self, node, seg, src):
-+ """
-+ """
-
- @abc.abstractmethod
- def close_gs_loop(self, node, seg, src):
-+ """
-+ """
-
- @abc.abstractmethod
- def close_st_loop(self, node, seg, src):
-+ """
-+ """
-
- @abc.abstractmethod
- def find_node(self, type):
-@@ -160,17 +166,23 @@ class ErrorHandlerBase(object):
-
- @abc.abstractmethod
- def _get_last_child(self):
--
-- @abc.abstractmethod
-+ """
-+ """
-
- @abc.abstractmethod
- def get_error_count(self):
-+ """
-+ """
-
- @abc.abstractmethod
- def get_first_child(self):
-+ """
-+ """
-
- @abc.abstractmethod
- def get_next_sibling(self):
-+ """
-+ """
-
- @abc.abstractmethod
- def __next__(self):