aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-qt4-xml/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-02-14 22:58:55 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-02-14 22:58:55 +0000
commit2d8b5de9c8741fee001355c270847ea6edebd952 (patch)
tree94cebcca98b96f7b4488709cf970696ac272c0e6 /textproc/py-qt4-xml/Makefile
parentde086ca81bb97192fb9cd50dba868f783132c321 (diff)
downloadports-2d8b5de9c8741fee001355c270847ea6edebd952.tar.gz
ports-2d8b5de9c8741fee001355c270847ea6edebd952.zip
Notes
Diffstat (limited to 'textproc/py-qt4-xml/Makefile')
-rw-r--r--textproc/py-qt4-xml/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index 6ca3b49925f5..e2dbcc83458b 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -6,15 +6,13 @@
PORTNAME= xml
PORTVERSION= ${PYQT4_VERSION}
-PORTREVISION= 2
PORTEPOCH= 1
-
CATEGORIES= textproc devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME= ${PYQT4_DISTNAME}
-MAINTAINER= ${PYQT_MAINTAINER}
+MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtXml module
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
@@ -23,7 +21,7 @@ RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-cor
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
USE_QT_VER= 4
-QT_COMPONENTS= xml qmake
+QT_COMPONENTS= xml qmake_build moc_build
OPTIONS= API "Install QtXml API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
@@ -33,11 +31,14 @@ OPTIONS= API "Install QtXml API for QScintilla2" on \
PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
+QSCIDIR= ${PREFIX}/share/qt4/qsci
CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
ARGS= -b ${PREFIX}/bin\
- -d ${PYTHON_SITELIBDIR}\
- -q ${QT_PREFIX}/bin/qmake-qt4\
- --confirm-license
+ -d ${PYTHONPREFIX_SITELIBDIR}\
+ -p ${PREFIX}/${QT_PLUGINDIR_REL}\
+ -q ${QMAKE}\
+ --confirm-license\
+ --enable QtXml
.include "../../devel/py-sip/files/bsd.pyqt.mk"
.include <bsd.port.pre.mk>
@@ -48,26 +49,21 @@ ARGS+= --debug
.if defined(WITHOUT_API)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
-PLIST_SUB+= APIFILE="@comment "
.else
-LIB_DEPENDS+= qscintilla2.3:${PORTSDIR}/devel/qscintilla2
-ARGS+= --qsci-api
+LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
-PLIST_SUB+= APIFILE="share/qt4/qsci/api/python/QtXml.api"
.endif
.if defined(WITHOUT_SIPFILES)
ARGS+= --no-sip-files
-PLIST_SUB+= SIPFILES="@comment "
-PLIST_SUB+= SIPDIR="@comment "
+PLIST_SUB+= SIP="@comment "
.else
ARGS+= --sipdir ${SIPDIR}
-PLIST_SUB+= SIPFILES=""
-PLIST_SUB+= SIPDIR="share/py-sip"
+PLIST_SUB+= SIP=""
.endif
.if defined(WITH_TRACING)
ARGS+= --trace
.endif
-ARGS+= --enable QtXml
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\