aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-qt4-xml
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-08 16:49:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-08 16:49:43 +0000
commit31469ae5656e71f14de03b31cf71b809859573d2 (patch)
tree344b6abf61ea06069f5de2c1cdcb8209791ac07e /textproc/py-qt4-xml
parent2625e8a3e3cca5d0659fb2fd36594a503ce698ca (diff)
PyQt: Replace bsd.pyqt.mk with Uses/pyqt.mk.
In preparation for landing PyQt5 ports, generalize devel/py-qt4's bsd.pyqt.mk and make it a proper file in Uses/. Ports wishing to depend on PyQt4 ports can now do the following: USES= pyqt:4 USE_PYQT= foo bar_build baz_run Other changes include the renaming of the PYQT4_DIST variable to PYQT_DIST and the introduction of the PYQT_SIPDIR plist substitution variable. The rest of the contents of Uses/pyqt.mk are pretty much identical to what we had in bsd.pyqt.mk with additional processing of USE_PYQT. Even though this patch touches files in many different ports, the goal is for it to be a no-op from an end-user perspective (so that the basic infrastructure is landed before the other, riskier changes): no dependencies have been changed, PyQt/SIP/QScintilla have not been upgraded and the plists should remain exactly the same, since PYQT_SIPDIR currently contains the same value that used to be hardcoded in the plists. Huge thanks to Guido Falsi (madpilot@) for spearheading most of the work: he took the initiative to work on PyQt5 and sent D2910 to Phabricator with the original version of this patch. Tobias Berner (tcberner@gmail.com) later applied it to kde@'s experimental area51 repositories and did some more work on it.
Notes
Notes: svn path=/head/; revision=403297
Diffstat (limited to 'textproc/py-qt4-xml')
-rw-r--r--textproc/py-qt4-xml/Makefile9
-rw-r--r--textproc/py-qt4-xml/pkg-plist8
2 files changed, 8 insertions, 9 deletions
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index 8dd5366bff66..f061ab48a5e0 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtXml module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core
-
CONFIGURE_ARGS= --enable QtXml
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build core_run
USE_QT4= xml qmake_build moc_build
OPTIONS_DEFINE= API DEBUG
@@ -25,5 +25,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>
diff --git a/textproc/py-qt4-xml/pkg-plist b/textproc/py-qt4-xml/pkg-plist
index 58d7239e1fe3..0b4d6871ec85 100644
--- a/textproc/py-qt4-xml/pkg-plist
+++ b/textproc/py-qt4-xml/pkg-plist
@@ -1,8 +1,8 @@
bin/pylupdate4
bin/pyrcc4
%%PYTHON_SITELIBDIR%%/PyQt4/QtXml.so
-share/py-sip/QtXml/QtXmlmod.sip
-share/py-sip/QtXml/qdom.sip
-share/py-sip/QtXml/qxml.sip
-share/py-sip/QtXml/qxmlstream.sip
+%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
+%%PYQT_SIPDIR%%/QtXml/qdom.sip
+%%PYQT_SIPDIR%%/QtXml/qxml.sip
+%%PYQT_SIPDIR%%/QtXml/qxmlstream.sip
%%API%%share/qt4/qsci/api/python/QtXml.api