aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-reverend/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-02 06:40:04 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-02 06:40:04 +0000
commit08114ec2c6a3b927c4a52bd44f2089e6930d0af9 (patch)
tree559a8fa6c0f47b8601fb54d48129388fe8f8a424 /textproc/py-reverend/Makefile
parent0c2bc2335d0dd5d8e6fde056863e3962c4001949 (diff)
Notes
Diffstat (limited to 'textproc/py-reverend/Makefile')
-rw-r--r--textproc/py-reverend/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/textproc/py-reverend/Makefile b/textproc/py-reverend/Makefile
index db76ad4c6d1e..8e97869d6a49 100644
--- a/textproc/py-reverend/Makefile
+++ b/textproc/py-reverend/Makefile
@@ -14,21 +14,16 @@ COMMENT= A simple Bayesian classifier written in Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Reverend
+OPTIONS_DEFINE= EXAMPLES
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-.if defined(WITHOUT_EXAMPLES)
-PORTEXAMPLES= "@comment "
-.else
-PORTEXAMPLES= ""
-.endif
-PLIST_SUB= PORTEXAMPLES=${PORTEXAMPLES}
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.if !defined(WITHOUT_EXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>