aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-snowballstemmer
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2015-08-06 07:07:33 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2015-08-06 07:07:33 +0000
commite782507e7f96221b9c48e1c3bc5d76a316955cfa (patch)
tree6387db27bb640e2bc4131137569f291ed0593c97 /textproc/py-snowballstemmer
parent5f4d144dad400f548ea8c69f18c5a7d8968bd284 (diff)
downloadports-e782507e7f96221b9c48e1c3bc5d76a316955cfa.tar.gz
ports-e782507e7f96221b9c48e1c3bc5d76a316955cfa.zip
Notes
Diffstat (limited to 'textproc/py-snowballstemmer')
-rw-r--r--textproc/py-snowballstemmer/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/textproc/py-snowballstemmer/Makefile b/textproc/py-snowballstemmer/Makefile
index fdd1d18231ef..fcb092ca1972 100644
--- a/textproc/py-snowballstemmer/Makefile
+++ b/textproc/py-snowballstemmer/Makefile
@@ -2,16 +2,27 @@
PORTNAME= snowballstemmer
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= kmoore@FreeBSD.org
-COMMENT= Pure Python stemming library
+COMMENT= Snowball stemming library collection for Python
-LICENSE= MIT
+LICENSE= BSD2CLAUSE
USES= python
USE_PYTHON= distutils autoplist
+OPTIONS_DEFINE= PYSTEMMER
+OPTIONS_DEFAULT=PYSTEMMER
+PYSTEMMER_DESC= Use PyStemmer to accelerate
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYSTEMMER}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pystemmer>0:${PORTSDIR}/textproc/py-pystemmer
+.endif
+
.include <bsd.port.mk>